An older version of nut is in oldpackages. This commit is based on that package and bumps the version to the latest release along with unifying the server and client packages. More build options are provided for any custom configuration but the defaults provide a working client and server install which only needs a UPS driver. Drivers still build as individual packages to minimise bloat. SSL support has also been added. Signed-off-by: Martin Rowe <cyanidium@users.noreply.github.com>
28 lines
769 B
Diff
28 lines
769 B
Diff
--- a/Makefile.in
|
|
+++ b/Makefile.in
|
|
@@ -431,12 +431,6 @@ distclean-libtool:
|
|
# (2) otherwise, pass the desired values on the `make' command line.
|
|
$(RECURSIVE_TARGETS):
|
|
@fail= failcom='exit 1'; \
|
|
- for f in x $$MAKEFLAGS; do \
|
|
- case $$f in \
|
|
- *=* | --[!k]*);; \
|
|
- *k*) failcom='fail=yes';; \
|
|
- esac; \
|
|
- done; \
|
|
dot_seen=no; \
|
|
target=`echo $@ | sed s/-recursive//`; \
|
|
list='$(SUBDIRS)'; for subdir in $$list; do \
|
|
@@ -456,12 +450,6 @@ $(RECURSIVE_TARGETS):
|
|
|
|
$(RECURSIVE_CLEAN_TARGETS):
|
|
@fail= failcom='exit 1'; \
|
|
- for f in x $$MAKEFLAGS; do \
|
|
- case $$f in \
|
|
- *=* | --[!k]*);; \
|
|
- *k*) failcom='fail=yes';; \
|
|
- esac; \
|
|
- done; \
|
|
dot_seen=no; \
|
|
case "$@" in \
|
|
distclean-* | maintainer-clean-*) list='$(DIST_SUBDIRS)' ;; \
|