packages/net/quassel-irssi/patches/002-use-cc-var.patch
Rosen Penev 0d25d561f3 quassel-irssi: Update to newer version to fix compilation
This is the irssi-abi-8 branch that was not merged back to master but is
necessary for compilation. As it touches a submodule, I can't add a patch
for it. But I can backport all of the master commits.

Get rid of quasselc dependency as it's now a submodule.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
2018-11-17 14:32:39 -08:00

11 lines
310 B
Diff

--- a/core/Makefile
+++ b/core/Makefile
@@ -48,7 +48,7 @@ irssi/network-openssl.o: CFLAGS:=$(IRSSI_CFLAGS)
quasselc-connector.o: CFLAGS:=$(CFLAGS)
$(TARGET): $(OBJECTS)
- gcc -shared $^ -o $@ -lz $(LDFLAGS)
+ $(CC) -shared $^ -o $@ -lz $(LDFLAGS)
install: $(TARGET)
$(INSTALL) -d $(IRSSI_LIB)/modules