packages/utils/gammu/patches/002-no-fstack-protector.patch
Rosen Penev ef6c6feef6 gammu: Update to 1.39.0
Cosmetic makefile changes.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
2018-08-11 14:28:32 -07:00

11 lines
410 B
Diff

--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -511,8 +511,6 @@ if(CMAKE_COMPILER_IS_GNUCC OR CMAKE_COMP
# MACRO_TUNE_LINKER("-pie")
# These do not work on Windows right now
if (NOT WIN32)
- # Stack protector
- MACRO_TUNE_COMPILER("-fstack-protector")
# Mark code read only
MACRO_TUNE_LINKER("-Wl,-zrelro")
endif (NOT WIN32)