packages/libs/quasselc/patches/001-respect-cflags-ldflags.patch
Ilya Lipnitskiy 5d8d4fbbcb
treewide: Run refresh on all packages
The crude loop I wrote to come up with this changeset:

  find -L package/feeds/packages/ -name patches | \
  sed 's/patches$/refresh/' | sort | xargs make

Signed-off-by: Ilya Lipnitskiy <ilya.lipnitskiy@gmail.com>
2021-02-20 16:02:15 -08:00

29 lines
997 B
Diff

--- a/Makefile
+++ b/Makefile
@@ -2,11 +2,11 @@ prefix ?= /usr/local
libdir ?= $(prefix)/lib
includedir ?= $(prefix)/include
-CFLAGS:=-Wall -g -Wextra $(shell pkg-config glib-2.0 --cflags) -Wswitch-enum -std=gnu11 -O2 -fPIC
+CFLAGS+=-Wall -g -Wextra $(shell pkg-config glib-2.0 --cflags) -Wswitch-enum -std=gnu11 -fPIC
SO_VERSION = 0
VERSION = 0
INSTALL = install
-LDLIBS:=$(shell pkg-config glib-2.0 --libs) -lz
+LDFLAGS+=$(shell pkg-config glib-2.0 --libs) -lz
BOTLIBS := -Wl,-rpath,.
@@ -15,10 +15,10 @@ lib_objects=setters.o getters.o main.o c
all: bot libquasselc.so.$(VERSION) quasselc.pc
libquasselc.so.$(VERSION): $(lib_objects)
- $(CC) -shared -o $@ -Wl,-soname,libquasselc.so.$(SO_VERSION) $^ $(LDLIBS)
+ $(CC) -shared -o $@ -Wl,-soname,libquasselc.so.$(SO_VERSION) $^ $(LDFLAGS)
bot: bot.o display.o libquasselc.so.$(VERSION)
- $(CC) -o $@ $^ $(LDLIBS) $(BOTLIBS)
+ $(CC) -o $@ $^ $(LDFLAGS) $(BOTLIBS)
clean:
rm -f *.o bot libquasselc.so.$(VERSION) quasselc.pc