Update collectd to version 5.9.0
* remove backported upstream patches (sensors, modbus)
* remove lua patch that has been been implemented upstream
(See collectd PR 3144)
* refresh patches and accommodate into upstream path changes
* place the 'stations' datatype for iwinfo in alpbetically
correct place in types.db
* add libmnl dependency to 'processes' plugin required for the
new Linux process Delay Accounting capability.
(Alternatively the capability & requirement might be patched away
in Makefile.am, HAVE_LIBTASKSTATS from collectd_4ea7a572)
* new plugins (disabled): ampq1, gpu_nvidia, pcie_errors,
write_stackdriver, write_syslog
compile-tested: ar71xx/WNDR3700 (all plugins)
run-tested: ar71xx/WNDR3700 (selected plugins)
Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
(cherry picked from commit 08d759f14a
)
11 lines
444 B
Diff
11 lines
444 B
Diff
--- a/src/ping.c
|
|
+++ b/src/ping.c
|
|
@@ -648,7 +648,7 @@ static int ping_read(void) /* {{{ */
|
|
((double)(pkg_recv * (pkg_recv - 1))));
|
|
|
|
/* Calculate drop rate. */
|
|
- droprate = ((double)(pkg_sent - pkg_recv)) / ((double)pkg_sent);
|
|
+ droprate = ((double)(pkg_sent - pkg_recv)) * 100 / ((double)pkg_sent);
|
|
|
|
submit(hl->host, "ping", latency_average);
|
|
submit(hl->host, "ping_stddev", latency_stddev);
|