Also already mentioned in ba4338d6f7
,
the security feature FORTIFY_SOURCE could be set globally.
The current approach tries to undefine and redefine it, however,
the order on the command line prevents this from being successfully, e.g.:
arm-openwrt-linux-muslgnueabi-gcc ... -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 ... -D_FORTIFY_SOURCE=1 ...
`---------------v-------------------' `--------v--------'
AM_CFLAGS OpenWrt params
So to have the original source (static) _FORTIFY_SOURCE=2 define,
the only option is to remove it from AM_CFLAGS completely, and
to pass it after the OpenWrt settings explicitely in the Makefile.
This should fix the buildbots finally.
Signed-off-by: Michael Heimpold <mhei@heimpold.de>
9 lines
190 B
Diff
9 lines
190 B
Diff
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -1,5 +1,5 @@
|
|
CC ?= gcc
|
|
-AM_CFLAGS = -D_FILE_OFFSET_BITS=64 -D_FORTIFY_SOURCE=2
|
|
+AM_CFLAGS = -D_FILE_OFFSET_BITS=64
|
|
CFLAGS ?= -g -O2
|
|
objects = \
|
|
mmc.o \
|