packages/net/haproxy/patches/010-add-uclibc-support.patch
Christian Lachner 01ec3b49a5 haproxy: Update HAProxy to v2.0.0 (LTS)
- Update haproxy download URL and hash
- Add new patches
- Add several CFLAGS (derived from haproxy Makefile) to make the build work with v1.9+
- Update default configuration
- Add check-command (for config) to init-script
- Add prometheus-service from contribs by default
- Add support for uclibc to haproxy with libcrypt disabled
- Minor cleanups

I have been running v2.0 for some time now and it feels as stable as v1.8. v2.0 is the new LTS release.

Signed-off-by: Christian Lachner <gladiac@gmail.com>
2019-06-24 23:08:52 +02:00

18 lines
610 B
Diff

--- a/Makefile
+++ b/Makefile
@@ -327,6 +327,15 @@ ifeq ($(TARGET),linux-glibc)
USE_GETADDRINFO)
endif
+# For linux >= 2.6.28 and uclibc
+ifeq ($(TARGET),linux-uclibc)
+ set_target_defaults = $(call default_opts, \
+ USE_POLL USE_TPROXY USE_DL USE_RT USE_NETFILTER \
+ USE_CPU_AFFINITY USE_THREAD USE_EPOLL USE_FUTEX USE_LINUX_TPROXY \
+ USE_ACCEPT4 USE_LINUX_SPLICE USE_PRCTL USE_THREAD_DUMP USE_NS USE_TFO \
+ USE_GETADDRINFO)
+endif
+
# Solaris 8 and above
ifeq ($(TARGET),solaris)
# We also enable getaddrinfo() which works since solaris 8.