C++ implementation of RSocket
RSocket is a binary protocol for use on byte stream transports such as
TCP, WebSockets, and Aeron. (https://rsocket.io/)
This ships with two separte libraries, yarpl and rsocket
Patch 100 is already upstream
(862202c6e9
).
Patch 101 in process of upstreaming as it needs to made compatible with
using both gold and ld.
[Dependency of https://github.com/facebook/openr]
Compile tested: openwrt master - nbg6817, arc700
Signed-off-by: Amol Bhave <ambhave@fb.com>
16 lines
779 B
Diff
16 lines
779 B
Diff
diff --git a/yarpl/CMakeLists.txt b/yarpl/CMakeLists.txt
|
|
--- a/yarpl/CMakeLists.txt Fri May 03 07:45:18 2019 -0700
|
|
+++ b/yarpl/CMakeLists.txt Tue May 07 02:03:23 2019 -0700
|
|
@@ -21,7 +21,11 @@
|
|
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -Wextra -Wno-unused-parameter")
|
|
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-weak-vtables -Wno-padded")
|
|
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fno-omit-frame-pointer")
|
|
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -momit-leaf-frame-pointer")
|
|
+ include(CheckCXXCompilerFlag)
|
|
+ CHECK_CXX_COMPILER_FLAG("-momit-leaf-frame-pointer" HAVE_OMIT_LEAF_FRAME_POINTER)
|
|
+ if(HAVE_OMIT_LEAF_FRAME_POINTER)
|
|
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -momit-leaf-frame-pointer")
|
|
+ endif()
|
|
endif()
|
|
|
|
if(YARPL_WRAP_SHARED_IN_LOCK)
|