Faster compilation. Before: time make package/zmq/compile -j 12 Executed in 24.98 secs fish external usr time 97.41 secs 263.00 micros 97.40 secs sys time 12.51 secs 34.00 micros 12.51 secs After: time make package/zmq/compile -j 12 Executed in 18.17 secs fish external usr time 85.22 secs 248.00 micros 85.22 secs sys time 9.23 secs 32.00 micros 9.23 secs Signed-off-by: Rosen Penev <rosenp@gmail.com>
20 lines
551 B
Diff
20 lines
551 B
Diff
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -3,6 +3,8 @@
|
|
cmake_minimum_required(VERSION 2.8.11)
|
|
project(ZeroMQ)
|
|
|
|
+include(FindPkgConfig)
|
|
+
|
|
option(WITH_OPENPGM "Build with support for OpenPGM" OFF)
|
|
|
|
if(APPLE)
|
|
@@ -21,7 +23,7 @@ if (NOT ENABLE_CURVE)
|
|
message (STATUS "CURVE security is disabled")
|
|
|
|
elseif (WITH_LIBSODIUM)
|
|
- find_package (Sodium)
|
|
+ pkg_search_module (SODIUM REQUIRED libsodium)
|
|
if (SODIUM_FOUND)
|
|
message (STATUS "Using libsodium for CURVE security")
|
|
include_directories (${SODIUM_INCLUDE_DIRS})
|