--- a/Makefile
+++ b/Makefile
@@ -12,8 +12,7 @@ KDIR	:= /lib/modules/$(shell uname -r)/build
 PWD	:= $(shell pwd)
 
 default:
-	$(MAKE) -C $(KDIR) SUBDIRS=$(PWD) modules
-	gcc -O2 -pipe -Wall dmx_usb_test.c -o dmx_usb_test
+	$(MAKE) -C $(KERNELPATH) SUBDIRS=$(PWD) modules
 
 endif