--- a/src/Mayaqua/CMakeLists.txt
+++ b/src/Mayaqua/CMakeLists.txt
@@ -55,7 +55,7 @@ if(UNIX)
   find_package(Threads REQUIRED)
 
   # In some cases libiconv is not included in libc
-  find_library(LIB_ICONV iconv)
+  find_library(LIB_ICONV iconv HINTS "${ICONV_LIB_PATH}")
 
   find_library(LIB_RT rt)