>>enable all IDs for hwinfo
>>changes to make it respect compile flags
>>disable the generation of "tiny hwinfo ID tables" because it is a long
process and has no purpose, it seems I cannot even build the "tiny" version of hwinfo
on my OpenSUSE system, so I guess that it is just legacy stuff that bitrotted.

--- a/src/ids/Makefile
+++ b/src/ids/Makefile
@@ -17,47 +17,47 @@ IDFILES	+= src/bus src/class src/extra s
 	  src/usb src/usb2 src/isapnp src/monitor src/camera src/tv2 src/tv src/dvb2 src/dvb \
 	  src/chipcard src/modem src/pcmcia src/s390 src/sdio
 
-ifeq "$(ARCH)" "i386"
+#ifeq "$(ARCH)" "i386"
 IDFILES += src/x11.i386 src/modem.i386
-endif
+#endif
 
-ifeq "$(ARCH)" "ppc"
+#ifeq "$(ARCH)" "ppc"
 IDFILES += src/x11.ppc src/x11.ppc.special
-endif
+#endif
 
-ifeq "$(ARCH)" "alpha"
+#ifeq "$(ARCH)" "alpha"
 IDFILES += src/x11.axp
-endif
+#endif
 
-ifeq "$(ARCH)" "sparc"
+#ifeq "$(ARCH)" "sparc"
 IDFILES += src/x11.sparc
-endif
+#endif
 
-ifeq "$(ARCH)" "sparc64"
+#ifeq "$(ARCH)" "sparc64"
 IDFILES += src/x11.sparc
-endif
+#endif
 
-ifeq "$(ARCH)" "ia64"
+#ifeq "$(ARCH)" "ia64"
 IDFILES += src/x11.ia64
-endif
+#endif
 
-ifeq "$(ARCH)" "x86_64"
+#ifeq "$(ARCH)" "x86_64"
 IDFILES += src/x11.amd64
-endif
+#endif
 
 IDFILES += src/pci src/storage src/sound src/mouse src/braille
 
 $(LIBHD_D): hd_ids.o
-	ar r $(LIBHD) $?
+	$(AR) r $(LIBHD) $?
 
 check_hd: check_hd.c
-	$(CC) $(CFLAGS) $< -o $@
+	$(CC) $(LDFLAGS) $(CFLAGS) $< -o $@
 
-hd_ids.c: hd_ids.h hd_ids_tiny.h
+hd_ids.c: hd_ids.h 
 
 hd_ids.h hd.ids: check_hd $(IDFILES)
 	./check_hd --check --sort --cfile hd_ids.h $(IDFILES)
 
-hd_ids_tiny.h: check_hd hd.ids
-	./check_hd --mini --cfile hd_ids_tiny.h --log=hd_tiny.log --out=hd_tiny.ids hd.ids
+#hd_ids_tiny.h: check_hd hd.ids
+#	./check_hd --mini --cfile hd_ids_tiny.h --log=hd_tiny.log --out=hd_tiny.ids hd.ids