--- a/src/port/Makefile
+++ b/src/port/Makefile
@@ -63,6 +63,7 @@ uninstall:
 libpgport.a: $(OBJS)
 	rm -f $@
 	$(AR) $(AROPT) $@ $^
+	$(RANLIB) libpgport.a
 
 # thread.o and thread_shlib.o need PTHREAD_CFLAGS (but thread_srv.o does not)
 thread.o: CFLAGS+=$(PTHREAD_CFLAGS)