hplip: bump to 3.19.3
040-fix_bool.patch: fixed upstream 060-fix-uclibc.patch: workaround for uclibc build (arc_arc700) Signed-off-by: Luiz Angelo Daros de Luca <luizluca@gmail.com>
This commit is contained in:
parent
57c8837af1
commit
fedc5cf5a4
3 changed files with 17 additions and 33 deletions
|
@ -9,12 +9,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=hplip
|
||||
PKG_VERSION:=3.18.12
|
||||
PKG_VERSION:=3.19.3
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@SF/hplip
|
||||
PKG_HASH:=3ba5278d5fcaf83ecd04d16850f2f24c43c78c1189c15ae32cae756360c2fabd
|
||||
PKG_HASH:=a04edf0b5b4c4dcaa3998a27caad8f24513340e0aea61b694397c7807d7c2ae6
|
||||
|
||||
PKG_MAINTAINER:=Luiz Angelo Daros de Luca <luizluca@gmail.com>
|
||||
PKG_LICENSE:=GPL-2.0 GPL-2.0+
|
||||
|
|
|
@ -1,31 +0,0 @@
|
|||
https://bugs.launchpad.net/hplip/+bug/1778626
|
||||
|
||||
--- a/prnt/hpcups/genPCLm.cpp
|
||||
+++ b/prnt/hpcups/genPCLm.cpp
|
||||
@@ -171,7 +171,7 @@ Defines
|
||||
#define rgb_2_gray(r,g,b) (ubyte)(0.299*(double)r+0.587*(double)g+0.114*(double)b)
|
||||
|
||||
// Note: this is required for debugging
|
||||
-boolean writeOutputFile(int numBytes, ubyte *ptr, char *user_name);
|
||||
+bool writeOutputFile(int numBytes, ubyte *ptr, char *user_name);
|
||||
|
||||
/*
|
||||
********************************************* Helper Routines **************************
|
||||
@@ -343,7 +343,7 @@ bool PCLmGenerator::addKids(sint32 kidObj)
|
||||
return(true);
|
||||
}
|
||||
|
||||
-boolean writeOutputFile(int numBytes, ubyte *ptr, char *user_name)
|
||||
+bool writeOutputFile(int numBytes, ubyte *ptr, char *user_name)
|
||||
{
|
||||
FILE *outputFile;
|
||||
char outFileName[MAX_FILE_PATH_LEN];
|
||||
@@ -1074,7 +1074,7 @@ void PCLmGenerator::writePDFGrammarPage(int imageWidth, int imageHeight, int num
|
||||
* Limitations:
|
||||
* -
|
||||
*****************************************************************************************/
|
||||
-boolean prepImageForBacksideDuplex(ubyte *imagePtr, sint32 imageHeight, sint32 imageWidth, sint32 numComponents)
|
||||
+bool prepImageForBacksideDuplex(ubyte *imagePtr, sint32 imageHeight, sint32 imageWidth, sint32 numComponents)
|
||||
{
|
||||
sint32 numBytes=imageHeight*imageWidth*numComponents;
|
||||
ubyte *head, *tail, t0, t1, t2;
|
15
utils/hplip/patches/060-fix-uclibc.patch
Normal file
15
utils/hplip/patches/060-fix-uclibc.patch
Normal file
|
@ -0,0 +1,15 @@
|
|||
Fix missing definition of uint64_t while compiling
|
||||
under uclibc
|
||||
|
||||
https://bugs.launchpad.net/hplip/+bug/1826965
|
||||
|
||||
--- a/scan/sane/OrbliteScan/LinuxCommon.h
|
||||
+++ b/scan/sane/OrbliteScan/LinuxCommon.h
|
||||
@@ -2,6 +2,7 @@
|
||||
#define H_LinuxCommon
|
||||
|
||||
#include <sys/types.h>
|
||||
+#include <stdint.h>
|
||||
|
||||
/* Common typedefs for Linux */
|
||||
|
Loading…
Reference in a new issue