perl: define $sysroot for extensions
Signed-off-by: Alexander Ryzhov <github@ryzhov-al.ru> Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
616b865697
commit
fed1b3b11b
3 changed files with 13 additions and 2 deletions
|
@ -11,7 +11,7 @@ include perlver.mk
|
|||
|
||||
PKG_NAME:=perl
|
||||
PKG_VERSION:=$(PERL_VERSION)
|
||||
PKG_RELEASE:=3
|
||||
PKG_RELEASE:=4
|
||||
|
||||
PKG_SOURCE_URL:=\
|
||||
https://cpan.metacpan.org/src/5.0 \
|
||||
|
@ -105,6 +105,7 @@ define Build/Configure
|
|||
-Dowrt:threads=$(if $(CONFIG_PERL_THREADS),yes,no) \
|
||||
-Dowrt:staging_dir='$(STAGING_DIR)' \
|
||||
-Dowrt:host_perl_prefix='$(HOST_PERL_PREFIX)' \
|
||||
-Dsysroot='$(TOOLCHAIN_DIR)' \
|
||||
files/version.config \
|
||||
files/base.config \
|
||||
files/$(patsubst i386,i486,$(ARCH)).config \
|
||||
|
|
|
@ -938,7 +938,6 @@ stdio_ptr='((fp)->_ptr)'
|
|||
stdio_stream_array=''
|
||||
submit=''
|
||||
sysman='/usr/share/man/man1'
|
||||
sysroot=''
|
||||
tail=''
|
||||
tar=''
|
||||
targetdir=''
|
||||
|
|
11
lang/perl/patches/998-Errno_errno.h_path.patch
Normal file
11
lang/perl/patches/998-Errno_errno.h_path.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- a/ext/Errno/Errno_pm.PL
|
||||
+++ b/ext/Errno/Errno_pm.PL
|
||||
@@ -133,7 +133,7 @@
|
||||
# Some Linuxes have weird errno.hs which generate
|
||||
# no #file or #line directives
|
||||
my ($linux_errno_h) = grep { -e $_ } map { "$_/errno.h" }
|
||||
- "$sysroot/usr/include", "$sysroot/usr/local/include",
|
||||
+ "$sysroot/usr/include", "$sysroot/usr/local/include", "$sysroot/include",
|
||||
split / / => $Config{locincpth} or
|
||||
die "Cannot find errno.h";
|
||||
$file{$linux_errno_h} = 1;
|
Loading…
Reference in a new issue