yggdrasil: bump to 0.3.15
Signed-off-by: George Iv <zhoreeq@users.noreply.github.com>
(cherry picked from commit 6b2b730181
)
This commit is contained in:
parent
8687d79f84
commit
fe9b2579f9
2 changed files with 3 additions and 36 deletions
|
@ -1,12 +1,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=yggdrasil
|
||||
PKG_VERSION:=0.3.14
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=0.3.15
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/yggdrasil-network/yggdrasil-go/tar.gz/v$(PKG_VERSION)?
|
||||
PKG_HASH:=e8579a04bf289434e7b8caaf621e2c0b853e83cc06f136c4f9e4bfc667df5a27
|
||||
PKG_HASH:=25ea85399a142aa7a3d6f6886fd4e0d215116c4c8c33453de43999787d735565
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-go-$(PKG_VERSION)
|
||||
|
||||
PKG_MAINTAINER:=William Fleurant <meshnet@protonmail.com>
|
||||
|
|
|
@ -1,33 +0,0 @@
|
|||
diff --git a/src/yggdrasil/tcp.go b/src/yggdrasil/tcp.go
|
||||
index 9cca419..45f93a5 100644
|
||||
--- a/src/yggdrasil/tcp.go
|
||||
+++ b/src/yggdrasil/tcp.go
|
||||
@@ -25,6 +25,7 @@ import (
|
||||
|
||||
"golang.org/x/net/proxy"
|
||||
|
||||
+ "github.com/yggdrasil-network/yggdrasil-go/src/address"
|
||||
"github.com/yggdrasil-network/yggdrasil-go/src/util"
|
||||
)
|
||||
|
||||
@@ -386,6 +387,19 @@ func (t *tcp) handler(sock net.Conn, incoming bool, options interface{}, upgrade
|
||||
local, _, _ = net.SplitHostPort(sock.LocalAddr().String())
|
||||
remote, _, _ = net.SplitHostPort(sock.RemoteAddr().String())
|
||||
}
|
||||
+ localIP := net.ParseIP(local)
|
||||
+ if localIP = localIP.To16(); localIP != nil {
|
||||
+ var laddr address.Address
|
||||
+ var lsubnet address.Subnet
|
||||
+ copy(laddr[:], localIP)
|
||||
+ copy(lsubnet[:], localIP)
|
||||
+ if laddr.IsValid() || lsubnet.IsValid() {
|
||||
+ // The local address is with the network address/prefix range
|
||||
+ // This would route ygg over ygg, which we don't want
|
||||
+ t.link.core.log.Debugln("Dropping ygg-tunneled connection", local, remote)
|
||||
+ return
|
||||
+ }
|
||||
+ }
|
||||
force := net.ParseIP(strings.Split(remote, "%")[0]).IsLinkLocalUnicast()
|
||||
link, err := t.link.core.link.create(&stream, name, proto, local, remote, incoming, force)
|
||||
if err != nil {
|
||||
|
Loading…
Reference in a new issue