fontconfig: update to 2.13.94
Remove upstreamed patches. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
7984d2d74a
commit
fe8060a90c
3 changed files with 3 additions and 46 deletions
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=fontconfig
|
||||
PKG_VERSION:=2.13.93
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=2.13.94
|
||||
PKG_RELEASE:=$(AUTORELEASE)
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=https://fontconfig.org/release/
|
||||
PKG_HASH:=ea968631eadc5739bc7c8856cef5c77da812d1f67b763f5e51b57b8026c1a0a0
|
||||
PKG_HASH:=a5f052cb73fd479ffb7b697980510903b563bbb55b8f7a2b001fcfb94026003c
|
||||
|
||||
PKG_MAINTAINER:=
|
||||
PKG_LICENSE:=
|
||||
|
|
|
@ -1,32 +0,0 @@
|
|||
From 4e42925096e97f4a6c9d09f475de7eb54a226668 Mon Sep 17 00:00:00 2001
|
||||
From: Heiko Becker <heirecka@exherbo.org>
|
||||
Date: Thu, 3 Dec 2020 21:04:26 +0100
|
||||
Subject: [PATCH] Handle absolute sysconfdir when installing symlinks
|
||||
|
||||
sysconfdir defaults to /etc when the prefix is set to /usr. But joining
|
||||
MESON_INSTALL_DESTDIR_PREFIX and sysconfdir when the latter is an
|
||||
absoulte path, results in sysconfdir only. Which might lead to an error
|
||||
during install because /etc/fonts/conf.d/ might already exist from an
|
||||
pre-existing fontconfig installation.
|
||||
---
|
||||
conf.d/link_confs.py | 9 ++++++++-
|
||||
1 file changed, 8 insertions(+), 1 deletion(-)
|
||||
|
||||
--- a/conf.d/link_confs.py
|
||||
+++ b/conf.d/link_confs.py
|
||||
@@ -11,7 +11,14 @@ if __name__=='__main__':
|
||||
parser.add_argument('links', nargs='+')
|
||||
args = parser.parse_args()
|
||||
|
||||
- confpath = os.path.join(os.environ['MESON_INSTALL_DESTDIR_PREFIX'], args.confpath)
|
||||
+ if os.path.isabs(args.confpath):
|
||||
+ destdir = os.environ.get('DESTDIR')
|
||||
+ if destdir:
|
||||
+ confpath = os.path.join(destdir, args.confpath[1:])
|
||||
+ else:
|
||||
+ confpath = args.confpath
|
||||
+ else:
|
||||
+ confpath = os.path.join(os.environ['MESON_INSTALL_DESTDIR_PREFIX'], args.confpath)
|
||||
|
||||
if not os.path.exists(confpath):
|
||||
os.makedirs(confpath)
|
|
@ -1,11 +0,0 @@
|
|||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -38,7 +38,7 @@ expat_dep = dependency('expat',
|
||||
|
||||
i18n = import('i18n')
|
||||
pkgmod = import('pkgconfig')
|
||||
-python3 = import('python').find_installation()
|
||||
+python3 = 'python3'
|
||||
|
||||
check_headers = [
|
||||
['dirent.h'],
|
Loading…
Reference in a new issue