python3-maxminddb: Fix build when using newer setuptools
This package fails to build with newer setuptools, because setuptools removed the (deprecated) Features feature in v46.0.0[1]. This adapts a commit[2] to remove the use of this feature. (Changes to code formatting prevent the original commit/patch to be used.) [1]:aff64ae89e/CHANGES.rst (v4600)
[2]:3aac426e35
Signed-off-by: Jeffery To <jeffery.to@gmail.com>
This commit is contained in:
parent
e1846e05e3
commit
fe32da0841
2 changed files with 34 additions and 1 deletions
|
@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=maxminddb
|
||||
PKG_VERSION:=1.4.1
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://files.pythonhosted.org/packages/source/m/maxminddb/
|
||||
|
|
|
@ -0,0 +1,33 @@
|
|||
Adapted from 3aac426[1] to account for a difference in formatting.
|
||||
|
||||
[1]: https://github.com/maxmind/MaxMind-DB-Reader-python/commit/3aac426e354f91814f6fd0829baee137b0bb093f
|
||||
|
||||
--- a/setup.py
|
||||
+++ b/setup.py
|
||||
@@ -9,7 +9,7 @@ from distutils.command.build_ext import
|
||||
from distutils.errors import (CCompilerError, DistutilsExecError,
|
||||
DistutilsPlatformError)
|
||||
|
||||
-from setuptools import setup, Extension, Feature
|
||||
+from setuptools import setup, Extension
|
||||
|
||||
cmdclass = {}
|
||||
PYPY = hasattr(sys, 'pypy_version_info')
|
||||
@@ -107,16 +107,7 @@ def find_packages(location):
|
||||
def run_setup(with_cext):
|
||||
kwargs = {}
|
||||
if with_cext:
|
||||
- if Feature:
|
||||
- kwargs['features'] = {
|
||||
- 'extension':
|
||||
- Feature(
|
||||
- "optional C implementation",
|
||||
- standard=True,
|
||||
- ext_modules=ext_module)
|
||||
- }
|
||||
- else:
|
||||
- kwargs['ext_modules'] = ext_module
|
||||
+ kwargs['ext_modules'] = ext_module
|
||||
|
||||
setup(
|
||||
name='maxminddb',
|
Loading…
Reference in a new issue