net-snmp: fix musl compatibility
Fixup `iwlib.h` to not consider an musl environment to be an unsupported platform. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
This commit is contained in:
parent
d9e391bbce
commit
fdde981522
2 changed files with 16 additions and 2 deletions
|
@ -1,5 +1,5 @@
|
|||
#
|
||||
# Copyright (C) 2006-2014 OpenWrt.org
|
||||
# Copyright (C) 2006-2015 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=net-snmp
|
||||
PKG_VERSION:=5.4.4
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@SF/net-snmp
|
||||
|
|
14
net/net-snmp/patches/900-musl-compat.patch
Normal file
14
net/net-snmp/patches/900-musl-compat.patch
Normal file
|
@ -0,0 +1,14 @@
|
|||
--- a/agent/mibgroup/iwlib.h
|
||||
+++ b/agent/mibgroup/iwlib.h
|
||||
@@ -85,6 +85,11 @@
|
||||
&& LINUX_VERSION_CODE < KERNEL_VERSION(2,1,0)
|
||||
#define LIBC5_HEADERS
|
||||
|
||||
+/* Musl */
|
||||
+#elif !defined(__GLIBC__) && !defined(__UCLIBC__) \
|
||||
+ && LINUX_VERSION_CODE >= KERNEL_VERSION(3,0,0)
|
||||
+#define GENERIC_HEADERS
|
||||
+
|
||||
/* Unsupported combination */
|
||||
#else
|
||||
#error "Your kernel/libc combination is not supported"
|
Loading…
Reference in a new issue