lxc: update to version 1.1.5
This commit is contained in:
parent
a91a6f5b5a
commit
fdacf2cd20
3 changed files with 14 additions and 6 deletions
|
@ -8,7 +8,7 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=lxc
|
||||
PKG_VERSION:=1.1.3
|
||||
PKG_VERSION:=1.1.5
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_LICENSE:=LGPL-2.1+ BSD-2-Clause GPL-2.0
|
||||
|
@ -16,7 +16,7 @@ PKG_MAINTAINER:=Luka Perkov <luka@openwrt.org>
|
|||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://linuxcontainers.org/downloads/lxc/
|
||||
PKG_MD5SUM:=197abb5a28ab0b689c737eb1951023fb
|
||||
PKG_MD5SUM:=dd9684dde0a58ed13f4f49c855b79a1a
|
||||
|
||||
PKG_BUILD_DEPENDS:=lua
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
--- a/src/lxc/utils.h
|
||||
+++ b/src/lxc/utils.h
|
||||
@@ -44,11 +44,7 @@ extern char *get_rundir(void);
|
||||
extern const char *lxc_global_config_value(const char *option_name);
|
||||
@@ -41,11 +41,7 @@ extern int mkdir_p(const char *dir, mode
|
||||
extern char *get_rundir(void);
|
||||
|
||||
/* Define getline() if missing from the C library */
|
||||
-#ifndef HAVE_GETLINE
|
||||
|
|
|
@ -1,12 +1,20 @@
|
|||
--- a/src/lxc/bdev.c
|
||||
+++ b/src/lxc/bdev.c
|
||||
@@ -1936,3 +1936,3 @@ static int loop_mount(struct bdev *bdev)
|
||||
@@ -1939,7 +1939,7 @@ static int find_free_loopdev(int *retfd,
|
||||
|
||||
static int loop_mount(struct bdev *bdev)
|
||||
{
|
||||
- int lfd, ffd = -1, ret = -1;
|
||||
+ int lfd = -1, ffd = -1, ret = -1;
|
||||
struct loop_info64 lo;
|
||||
@@ -1974,3 +1974,3 @@ out:
|
||||
char loname[100];
|
||||
|
||||
@@ -1977,7 +1977,7 @@ out:
|
||||
if (ffd > -1)
|
||||
close(ffd);
|
||||
if (ret < 0) {
|
||||
- close(lfd);
|
||||
+ if (lfd > -1) close(lfd);
|
||||
bdev->lofd = -1;
|
||||
}
|
||||
return ret;
|
||||
|
|
Loading…
Reference in a new issue