libssh2: version bump
- Bump version to 1.8.0 - Switch from openssl crypto backend to mbedtls (the package is a lot smaller size-wise compared to openssl and libgcrypt) - mbedtls support was added in 1.8.0 release. Unfortunately the detection doesn't work out of the box, so a patch is needed that fixes an m4 script. For that reason autoreconf must be run. - Add --with-libz-prefix as without it zlib is not detected (currently there is the zlib dependency but libssh2 never actually links to it). - Add --disable-silent-rules to get verbose build output. Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
This commit is contained in:
parent
dfcb2ca77c
commit
fd953af246
2 changed files with 40 additions and 7 deletions
|
@ -1,5 +1,5 @@
|
||||||
#
|
#
|
||||||
# Copyright (C) 2015-2016 OpenWrt.org
|
# Copyright (C) 2015-2018 OpenWrt.org
|
||||||
#
|
#
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
|
@ -8,12 +8,14 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=libssh2
|
PKG_NAME:=libssh2
|
||||||
PKG_VERSION:=1.7.0
|
PKG_VERSION:=1.8.0
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=http://www.libssh2.org/download
|
PKG_SOURCE_URL:=https://www.libssh2.org/download
|
||||||
PKG_HASH:=e4561fd43a50539a8c2ceb37841691baf03ecb7daf043766da1b112e4280d584
|
PKG_HASH:=39f34e2f6835f4b992cafe8625073a88e5a28ba78f83e8099610a7b3af4676d4
|
||||||
|
|
||||||
|
PKG_FIXUP:=autoreconf
|
||||||
|
|
||||||
PKG_INSTALL:=1
|
PKG_INSTALL:=1
|
||||||
|
|
||||||
|
@ -26,8 +28,8 @@ define Package/libssh2
|
||||||
SECTION:=libs
|
SECTION:=libs
|
||||||
CATEGORY:=Libraries
|
CATEGORY:=Libraries
|
||||||
TITLE:=SSH2 library
|
TITLE:=SSH2 library
|
||||||
URL:=http://www.libssh2.org/
|
URL:=https://www.libssh2.org/
|
||||||
DEPENDS:=+libopenssl +zlib
|
DEPENDS:=+libmbedtls +zlib
|
||||||
MAINTAINER:=Jiri Slachta <jiri@slachta.eu>
|
MAINTAINER:=Jiri Slachta <jiri@slachta.eu>
|
||||||
endef
|
endef
|
||||||
|
|
||||||
|
@ -39,7 +41,10 @@ TARGET_CFLAGS += $(FPIC)
|
||||||
|
|
||||||
CONFIGURE_ARGS += \
|
CONFIGURE_ARGS += \
|
||||||
--disable-examples-build \
|
--disable-examples-build \
|
||||||
--with-libssl-prefix=$(STAGING_DIR)/usr
|
--disable-silent-rules \
|
||||||
|
--with-mbedtls \
|
||||||
|
--with-libmbedtls-prefix=$(STAGING_DIR)/usr \
|
||||||
|
--with-libz-prefix=$(STAGING_DIR)/usr
|
||||||
|
|
||||||
define Build/InstallDev
|
define Build/InstallDev
|
||||||
$(INSTALL_DIR) $(1)/usr/include
|
$(INSTALL_DIR) $(1)/usr/include
|
||||||
|
|
28
libs/libssh2/patches/01-fix-acinclude-m4.patch
Normal file
28
libs/libssh2/patches/01-fix-acinclude-m4.patch
Normal file
|
@ -0,0 +1,28 @@
|
||||||
|
--- a/acinclude.m4
|
||||||
|
+++ b/acinclude.m4
|
||||||
|
@@ -386,9 +386,9 @@ AC_DEFUN([LIBSSH2_CHECKFOR_MBEDTLS], [
|
||||||
|
|
||||||
|
old_LDFLAGS=$LDFLAGS
|
||||||
|
old_CFLAGS=$CFLAGS
|
||||||
|
- if test -n "$use_mbedtls" && test "$use_mbedtls" != "no"; then
|
||||||
|
- LDFLAGS="$LDFLAGS -L$use_mbedtls/lib"
|
||||||
|
- CFLAGS="$CFLAGS -I$use_mbedtls/include"
|
||||||
|
+ if test -n "$with_libmbedtls_prefix" && test "$use_mbedtls" != "no"; then
|
||||||
|
+ LDFLAGS="$LDFLAGS -L$with_libmbedtls_prefix/lib"
|
||||||
|
+ CFLAGS="$CFLAGS -I$with_libmbedtls_prefix/include"
|
||||||
|
fi
|
||||||
|
|
||||||
|
AC_LIB_HAVE_LINKFLAGS([mbedtls], [], [
|
||||||
|
@@ -412,9 +412,9 @@ AC_DEFUN([LIBSSH2_CHECKFOR_GCRYPT], [
|
||||||
|
|
||||||
|
old_LDFLAGS=$LDFLAGS
|
||||||
|
old_CFLAGS=$CFLAGS
|
||||||
|
- if test -n "$use_libgcrypt" && test "$use_libgcrypt" != "no"; then
|
||||||
|
- LDFLAGS="$LDFLAGS -L$use_libgcrypt/lib"
|
||||||
|
- CFLAGS="$CFLAGS -I$use_libgcrypt/include"
|
||||||
|
+ if test -n "$with_libgcrypt_prefix" && test "$use_libgcrypt" != "no"; then
|
||||||
|
+ LDFLAGS="$LDFLAGS -L$with_libgcrypt_prefix/lib"
|
||||||
|
+ CFLAGS="$CFLAGS -I$with_libgcrypt_prefix/include"
|
||||||
|
fi
|
||||||
|
AC_LIB_HAVE_LINKFLAGS([gcrypt], [], [
|
||||||
|
#include <gcrypt.h>
|
Loading…
Reference in a new issue