wget: apply upstream fix to avoid nettle linking in nossl
Replace my own patch with the upstream solution, which they issued in response to my bug report. (Two patches as they overlooked something on the first try. Reference to https://savannah.gnu.org/bugs/index.php?63431 ) The nettle lib evaluation is now conditional to not having "--disable-ntlm". Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
This commit is contained in:
parent
dd7e606f17
commit
fd7da3333e
4 changed files with 91 additions and 19 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=wget
|
||||
PKG_VERSION:=1.21.3
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
|
||||
|
|
|
@ -1,18 +0,0 @@
|
|||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -630,6 +630,7 @@ then
|
||||
AC_DEFINE([ENABLE_NTLM], 1, [Define if you want the NTLM authorization support compiled in.])
|
||||
fi
|
||||
else
|
||||
+ if test x"$ENABLE_NTLM" != xno; then
|
||||
PKG_CHECK_MODULES([NETTLE], nettle, [
|
||||
HAVE_NETTLE=yes
|
||||
LIBS="$NETTLE_LIBS $LIBS"
|
||||
@@ -651,6 +652,7 @@ else
|
||||
ENABLE_NTLM=yes
|
||||
AC_DEFINE([ENABLE_NTLM], 1, [Define if you want the NTLM authorization support compiled in.])
|
||||
fi
|
||||
+ fi
|
||||
fi
|
||||
|
||||
dnl **********************************************************************
|
25
net/wget/patches/001-upstream-fix-disable-ntlm-1.patch
Normal file
25
net/wget/patches/001-upstream-fix-disable-ntlm-1.patch
Normal file
|
@ -0,0 +1,25 @@
|
|||
From 485217d0ff8d0d17ea3815244b2bc2b747451e15 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Tim=20R=C3=BChsen?= <tim.ruehsen@gmx.de>
|
||||
Date: Sat, 10 Dec 2022 16:43:38 +0100
|
||||
Subject: [PATCH] * configure.ac: Allow disabling NTLM if nettle present (Savannah #63431)
|
||||
|
||||
---
|
||||
configure.ac | 7 +++++--
|
||||
1 file changed, 5 insertions(+), 2 deletions(-)
|
||||
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -648,8 +648,11 @@ else
|
||||
|
||||
if test x"$HAVE_NETTLE" = xyes; then
|
||||
AC_DEFINE([HAVE_NETTLE], [1], [Use libnettle])
|
||||
- ENABLE_NTLM=yes
|
||||
- AC_DEFINE([ENABLE_NTLM], 1, [Define if you want the NTLM authorization support compiled in.])
|
||||
+ if test x"$ENABLE_NTLM" != xno
|
||||
+ then
|
||||
+ ENABLE_NTLM=yes
|
||||
+ AC_DEFINE([ENABLE_NTLM], 1, [Define if you want the NTLM authorization support compiled in.])
|
||||
+ fi
|
||||
fi
|
||||
fi
|
||||
|
65
net/wget/patches/002-upstream-fix-disable-ntlm-2.patch
Normal file
65
net/wget/patches/002-upstream-fix-disable-ntlm-2.patch
Normal file
|
@ -0,0 +1,65 @@
|
|||
From c69030a904f8ab25b9ca2704c8a6dd03554e9503 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Tim=20R=C3=BChsen?= <tim.ruehsen@gmx.de>
|
||||
Date: Sun, 11 Dec 2022 13:31:38 +0100
|
||||
Subject: [PATCH] * configure.ac: Disable nettle if NTLM is explicitly disabled
|
||||
|
||||
---
|
||||
configure.ac | 41 +++++++++++++++++++----------------------
|
||||
1 file changed, 19 insertions(+), 22 deletions(-)
|
||||
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -622,34 +622,31 @@ AS_IF([test x"$with_ssl" = xopenssl], [
|
||||
]) # endif: --with-ssl == openssl?
|
||||
|
||||
dnl Enable NTLM if requested and if SSL is available.
|
||||
-if test x"$LIBSSL" != x || test "$ac_cv_lib_ssl32_SSL_connect" = yes
|
||||
+if test x"$ENABLE_NTLM" != xno
|
||||
then
|
||||
- if test x"$ENABLE_NTLM" != xno
|
||||
+ if test x"$LIBSSL" != x || test "$ac_cv_lib_ssl32_SSL_connect" = yes
|
||||
then
|
||||
ENABLE_NTLM=yes
|
||||
AC_DEFINE([ENABLE_NTLM], 1, [Define if you want the NTLM authorization support compiled in.])
|
||||
- fi
|
||||
-else
|
||||
- PKG_CHECK_MODULES([NETTLE], nettle, [
|
||||
- HAVE_NETTLE=yes
|
||||
- LIBS="$NETTLE_LIBS $LIBS"
|
||||
- CFLAGS="$NETTLE_CFLAGS $CFLAGS"
|
||||
- ], [
|
||||
- AC_CHECK_LIB(nettle, nettle_md4_init, [HAVE_NETTLE=yes], [HAVE_NETTLE=no; AC_MSG_WARN(*** libnettle was not found. You will not be able to use NTLM)])
|
||||
- if test x"$HAVE_NETTLE" != xyes; then
|
||||
- if test x"$ENABLE_NTLM" = xyes; then
|
||||
- AC_MSG_ERROR([NTLM authorization requested and SSL not enabled; aborting])
|
||||
- fi
|
||||
- else
|
||||
- AC_SUBST(NETTLE_LIBS, "-lnettle")
|
||||
+ else
|
||||
+ PKG_CHECK_MODULES([NETTLE], nettle, [
|
||||
+ HAVE_NETTLE=yes
|
||||
LIBS="$NETTLE_LIBS $LIBS"
|
||||
- fi
|
||||
- ])
|
||||
+ CFLAGS="$NETTLE_CFLAGS $CFLAGS"
|
||||
+ ], [
|
||||
+ AC_CHECK_LIB(nettle, nettle_md4_init, [HAVE_NETTLE=yes], [HAVE_NETTLE=no; AC_MSG_WARN(*** libnettle was not found. You will not be able to use NTLM)])
|
||||
+ if test x"$HAVE_NETTLE" != xyes; then
|
||||
+ if test x"$ENABLE_NTLM" = xyes; then
|
||||
+ AC_MSG_ERROR([NTLM authorization requested and SSL not enabled; aborting])
|
||||
+ fi
|
||||
+ else
|
||||
+ AC_SUBST(NETTLE_LIBS, "-lnettle")
|
||||
+ LIBS="$NETTLE_LIBS $LIBS"
|
||||
+ fi
|
||||
+ ])
|
||||
|
||||
- if test x"$HAVE_NETTLE" = xyes; then
|
||||
- AC_DEFINE([HAVE_NETTLE], [1], [Use libnettle])
|
||||
- if test x"$ENABLE_NTLM" != xno
|
||||
- then
|
||||
+ if test x"$HAVE_NETTLE" = xyes; then
|
||||
+ AC_DEFINE([HAVE_NETTLE], [1], [Use libnettle])
|
||||
ENABLE_NTLM=yes
|
||||
AC_DEFINE([ENABLE_NTLM], 1, [Define if you want the NTLM authorization support compiled in.])
|
||||
fi
|
Loading…
Reference in a new issue