flashrom: fix build with musl
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
This commit is contained in:
parent
81f9889bb0
commit
fc959cf5b8
2 changed files with 13 additions and 1 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=flashrom
|
PKG_NAME:=flashrom
|
||||||
PKG_VERSION:=0.9.8
|
PKG_VERSION:=0.9.8
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=3
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
PKG_SOURCE_URL:=http://download.flashrom.org/releases
|
PKG_SOURCE_URL:=http://download.flashrom.org/releases
|
||||||
|
|
12
utils/flashrom/patches/0002-fix-musl-compatibility.patch
Normal file
12
utils/flashrom/patches/0002-fix-musl-compatibility.patch
Normal file
|
@ -0,0 +1,12 @@
|
||||||
|
diff -uprN a/linux_spi.c b/linux_spi.c
|
||||||
|
--- a/linux_spi.c 2015-06-17 20:50:36.492963100 +0200
|
||||||
|
+++ b/linux_spi.c 2015-06-17 20:50:00.444860800 +0200
|
||||||
|
@@ -22,7 +22,7 @@
|
||||||
|
#include <stdio.h>
|
||||||
|
#include <string.h>
|
||||||
|
#include <stdlib.h>
|
||||||
|
-#include <sys/fcntl.h>
|
||||||
|
+#include <fcntl.h>
|
||||||
|
#include <errno.h>
|
||||||
|
#include <ctype.h>
|
||||||
|
#include <unistd.h>
|
Loading…
Reference in a new issue