commit
fc79b1bce5
3 changed files with 19 additions and 45 deletions
|
@ -8,26 +8,30 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=sysstat
|
PKG_NAME:=sysstat
|
||||||
PKG_VERSION:=12.0.5
|
PKG_VERSION:=12.2.1
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_LICENSE:=GPL-2.0
|
|
||||||
PKG_MAINTAINER:=Marko Ratkaj <marko.ratkaj@sartura.hr>
|
|
||||||
PKG_CPE_ID:=cpe:/a:sysstat:sysstat
|
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||||
PKG_SOURCE_URL:=http://pagesperso-orange.fr/sebastien.godard/
|
PKG_SOURCE_URL:=http://pagesperso-orange.fr/sebastien.godard/
|
||||||
PKG_HASH:=58583b0776b9addec69e42eebd6dd1a8e976da8a36bad2422659a1ad6c1a2600
|
PKG_HASH:=8edb0e19b514ac560a098a02933a4735b881296d61014db89bf80f05dd7a4732
|
||||||
|
|
||||||
|
PKG_MAINTAINER:=Marko Ratkaj <marko.ratkaj@sartura.hr>
|
||||||
|
PKG_LICENSE:=GPL-2.0-or-later
|
||||||
|
PKG_LICENSE_FILES:=COPYING
|
||||||
|
PKG_CPE_ID:=cpe:/a:sysstat_project:sysstat
|
||||||
|
|
||||||
PKG_INSTALL:=1
|
PKG_INSTALL:=1
|
||||||
|
PKG_BUILD_PARALLEL:=1
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
include $(INCLUDE_DIR)/nls.mk
|
||||||
|
|
||||||
define Package/sysstat
|
define Package/sysstat
|
||||||
SECTION:=utils
|
SECTION:=utils
|
||||||
CATEGORY:=Utilities
|
CATEGORY:=Utilities
|
||||||
TITLE:=Sysstat performance monitoring tools
|
TITLE:=Sysstat performance monitoring tools
|
||||||
URL:=http://pagesperso-orange.fr/sebastien.godard/index.html
|
URL:=http://pagesperso-orange.fr/sebastien.godard/index.html
|
||||||
|
DEPENDS:=$(INTL_DEPENDS)
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/sysstat/description
|
define Package/sysstat/description
|
||||||
|
@ -47,9 +51,7 @@ CONFIGURE_VARS+= \
|
||||||
|
|
||||||
CONFIGURE_ARGS+= \
|
CONFIGURE_ARGS+= \
|
||||||
--disable-documentation \
|
--disable-documentation \
|
||||||
--disable-largefile \
|
--disable-sensors
|
||||||
--disable-sensors \
|
|
||||||
--disable-nls
|
|
||||||
|
|
||||||
define Package/sysstat/install
|
define Package/sysstat/install
|
||||||
$(INSTALL_DIR) $(1)/usr/lib/sysstat
|
$(INSTALL_DIR) $(1)/usr/lib/sysstat
|
||||||
|
|
|
@ -26,12 +26,14 @@ start_sysstat_instance() {
|
||||||
|
|
||||||
[ -d /var/log/sysstat ] || mkdir -p /var/log/sysstat
|
[ -d /var/log/sysstat ] || mkdir -p /var/log/sysstat
|
||||||
|
|
||||||
echo "HISTORY=$log_history" > $SYSSTAT_CFG
|
{
|
||||||
echo "COMPRESSAFTER=$compressafter" >> $SYSSTAT_CFG
|
echo "HISTORY=$log_history"
|
||||||
echo "SADC_OPTIONS=\"$sadc_options\"" >> $SYSSTAT_CFG
|
echo "COMPRESSAFTER=$compressafter"
|
||||||
echo "SA_DIR=\"$sa_dir\"" >> $SYSSTAT_CFG
|
echo "SADC_OPTIONS=\"$sadc_options\""
|
||||||
echo "ZIP=\"$zip\"" >> $SYSSTAT_CFG
|
echo "SA_DIR=\"$sa_dir\""
|
||||||
echo "ENABLED=\"$enabled\"" >> $SYSSTAT_CFG
|
echo "ZIP=\"$zip\""
|
||||||
|
echo "ENABLED=\"$enabled\""
|
||||||
|
} > $SYSSTAT_CFG
|
||||||
|
|
||||||
procd_open_instance
|
procd_open_instance
|
||||||
procd_set_param command $PROG -S DISK -F -L -
|
procd_set_param command $PROG -S DISK -F -L -
|
||||||
|
|
|
@ -1,30 +0,0 @@
|
||||||
--- a/sa_common.c
|
|
||||||
+++ b/sa_common.c
|
|
||||||
@@ -29,6 +29,7 @@
|
|
||||||
#include <dirent.h>
|
|
||||||
#include <fcntl.h>
|
|
||||||
#include <libgen.h>
|
|
||||||
+#include <limits.h>
|
|
||||||
#include <sys/types.h>
|
|
||||||
#include <sys/stat.h>
|
|
||||||
#include <ctype.h>
|
|
||||||
--- a/common.c
|
|
||||||
+++ b/common.c
|
|
||||||
@@ -32,6 +32,7 @@
|
|
||||||
#include <dirent.h>
|
|
||||||
#include <ctype.h>
|
|
||||||
#include <libgen.h>
|
|
||||||
+#include <limits.h>
|
|
||||||
|
|
||||||
#include "version.h"
|
|
||||||
#include "common.h"
|
|
||||||
--- a/ioconf.c
|
|
||||||
+++ b/ioconf.c
|
|
||||||
@@ -27,6 +27,7 @@
|
|
||||||
#include <errno.h>
|
|
||||||
#include <dirent.h>
|
|
||||||
#include <sys/stat.h>
|
|
||||||
+#include <sys/types.h>
|
|
||||||
|
|
||||||
#include "ioconf.h"
|
|
||||||
#include "common.h"
|
|
Loading…
Reference in a new issue