glib2: update to 2.58.1
Signed-off-by: Peter Wagner <tripolar@gmx.at>
This commit is contained in:
parent
06579f632e
commit
fc212923d5
2 changed files with 23 additions and 17 deletions
|
@ -8,13 +8,13 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=glib2
|
||||
PKG_VERSION:=2.56.1
|
||||
PKG_RELEASE:=1
|
||||
PKG_VERSION:=2.58.1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=glib-$(PKG_VERSION).tar.xz
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/glib-$(PKG_VERSION)
|
||||
PKG_SOURCE_URL:=@GNOME/glib/2.56
|
||||
PKG_HASH:=40ef3f44f2c651c7a31aedee44259809b6f03d3d20be44545cd7d177221c0b8d
|
||||
PKG_SOURCE_URL:=@GNOME/glib/2.58
|
||||
PKG_HASH:=97d6a9d926b6aa3dfaadad3077cfb43eec74432ab455dff14250c769d526d7d6
|
||||
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
HOST_BUILD_PARALLEL:=1
|
||||
|
@ -44,19 +44,23 @@ define Package/glib2/description
|
|||
The GLib library of C routines
|
||||
endef
|
||||
|
||||
TARGET_CFLAGS += -Wno-error=implicit-function-declaration
|
||||
|
||||
HOST_CONFIGURE_ARGS += \
|
||||
--disable-selinux \
|
||||
--with-libiconv=gnu \
|
||||
--with-pcre=internal \
|
||||
--enable-libmount=no
|
||||
--disable-libmount
|
||||
|
||||
CONFIGURE_ARGS += \
|
||||
--enable-shared \
|
||||
--enable-static \
|
||||
--enable-debug=no \
|
||||
--disable-debug \
|
||||
--disable-selinux \
|
||||
--enable-libmount=no \
|
||||
--disable-libmount \
|
||||
--disable-fam \
|
||||
--disable-gtk-doc-html \
|
||||
--disable-man \
|
||||
--with-libiconv=gnu \
|
||||
--with-pcre=internal
|
||||
|
||||
|
@ -69,6 +73,11 @@ CONFIGURE_VARS += \
|
|||
ac_cv_func_posix_getgrgid_r=yes
|
||||
|
||||
define Build/InstallDev
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(CP) \
|
||||
$(PKG_INSTALL_DIR)/usr/bin/* \
|
||||
$(1)/usr/bin/
|
||||
|
||||
$(INSTALL_DIR) $(1)/usr/include
|
||||
$(CP) \
|
||||
$(PKG_INSTALL_DIR)/usr/include/glib-2.0 \
|
||||
|
|
|
@ -1,11 +1,8 @@
|
|||
--- a/gtk-doc.make
|
||||
diff --git a/gtk-doc.make b/gtk-doc.make
|
||||
new file mode 100644
|
||||
index 0000000..14f18fd
|
||||
--- /dev/null
|
||||
+++ b/gtk-doc.make
|
||||
@@ -298,7 +298,7 @@ uninstall-local:
|
||||
#
|
||||
# Require gtk-doc when making dist
|
||||
#
|
||||
-if HAVE_GTK_DOC
|
||||
+if ENABLE_GTK_DOC
|
||||
dist-check-gtkdoc: docs
|
||||
else
|
||||
dist-check-gtkdoc:
|
||||
@@ -0,0 +1,2 @@
|
||||
+EXTRA_DIST =
|
||||
+CLEANFILES =
|
||||
|
|
Loading…
Reference in a new issue