libfolly: Update to 2019.10.07.00
Added patch to remove boost-thread.
Removed uClibc-ng patch. libfolly no longer builds there.
Signed-off-by: Rosen Penev <rosenp@gmail.com>
(cherry-picked from b9000043bf
)
This commit is contained in:
parent
3b1cf245fe
commit
fbc1c29a7d
4 changed files with 23 additions and 38 deletions
|
@ -1,14 +1,13 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=libfolly
|
||||
PKG_VERSION:=2019.09.22.00
|
||||
PKG_VERSION:=2019.10.07.00
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_VERSION:=af2373b9858c61685eb6eb2f1db99d9a31edd58e
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/facebook/folly/tar.gz/$(PKG_SOURCE_VERSION)?
|
||||
PKG_HASH:=fbf25a96e5487fcd959ff50ff1c5413c8e18b8aaa9af3d2406156d750167affd
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/folly-$(PKG_SOURCE_VERSION)
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/facebook/folly/tar.gz/v$(PKG_VERSION)?
|
||||
PKG_HASH:=3c8ab22e551ff73509aa008454d5e15da9a05b64bc20450459c3da2471729fff
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/folly-$(PKG_VERSION)
|
||||
|
||||
PKG_MAINTAINER:=Amol Bhave <ambhave@fb.com>
|
||||
PKG_LICENSE:=Apache-2.0
|
||||
|
@ -25,7 +24,7 @@ define Package/libfolly
|
|||
CATEGORY:=Libraries
|
||||
TITLE:=An open-source C++ library developed and used at Facebook.
|
||||
URL:=https://github.com/facebook/folly
|
||||
DEPENDS:=+boost +boost-context +boost-date_time +boost-filesystem +boost-program_options +boost-regex \
|
||||
DEPENDS:=+boost +boost-context +boost-filesystem +boost-program_options +boost-regex \
|
||||
+libopenssl +libdouble-conversion +libevent2 +glog +libsodium +libaio +libatomic \
|
||||
+libbz2 +zlib +libzstd +liblzma +liblz4 +PACKAGE_libunwind:libunwind
|
||||
endef
|
||||
|
@ -39,8 +38,8 @@ define Package/libfolly/description
|
|||
endef
|
||||
|
||||
CMAKE_OPTIONS += \
|
||||
-DBUILD_SHARED_LIBS=ON \
|
||||
-DCMAKE_POSITION_INDEPENDENT_CODE=ON \
|
||||
-DCXX_STD=c++14 \
|
||||
-DFOLLY_HAVE_UNALIGNED_ACCESS_EXITCODE=OFF \
|
||||
-DFOLLY_HAVE_UNALIGNED_ACCESS_EXITCODE__TRYRUN_OUTPUT=OFF \
|
||||
-DFOLLY_HAVE_LINUX_VDSO_EXITCODE=OFF \
|
||||
|
@ -48,8 +47,7 @@ CMAKE_OPTIONS += \
|
|||
-DFOLLY_HAVE_WCHAR_SUPPORT_EXITCODE=OFF \
|
||||
-DFOLLY_HAVE_WCHAR_SUPPORT_EXITCODE__TRYRUN_OUTPUT=OFF \
|
||||
-DHAVE_VSNPRINTF_ERRORS_EXITCODE=OFF \
|
||||
-DHAVE_VSNPRINTF_ERRORS_EXITCODE__TRYRUN_OUTPUT=OFF \
|
||||
-DBUILD_SHARED_LIBS=ON
|
||||
-DHAVE_VSNPRINTF_ERRORS_EXITCODE__TRYRUN_OUTPUT=OFF
|
||||
|
||||
TARGET_CXXFLAGS += -ffunction-sections -fdata-sections -flto
|
||||
TARGET_LDFLAGS += -Wl,--gc-sections,--as-needed
|
||||
|
|
|
@ -1,8 +1,6 @@
|
|||
Index: folly-2019.05.06.00/CMakeLists.txt
|
||||
===================================================================
|
||||
--- folly-2019.05.06.00.orig/CMakeLists.txt
|
||||
+++ folly-2019.05.06.00/CMakeLists.txt
|
||||
@@ -109,17 +109,19 @@ configure_file(
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -112,17 +112,19 @@ configure_file(
|
||||
auto_sources(files "*.cpp" "RECURSE" "${FOLLY_DIR}")
|
||||
auto_sources(hfiles "*.h" "RECURSE" "${FOLLY_DIR}")
|
||||
|
||||
|
@ -29,7 +27,7 @@ Index: folly-2019.05.06.00/CMakeLists.txt
|
|||
"Benchmark.cpp$"
|
||||
"Test.cpp$"
|
||||
)
|
||||
@@ -172,7 +174,7 @@ list(APPEND hfiles
|
||||
@@ -175,7 +177,7 @@ list(APPEND hfiles
|
||||
if (NOT FOLLY_USE_SYMBOLIZER)
|
||||
REMOVE_MATCHES_FROM_LISTS(files hfiles
|
||||
MATCHES
|
||||
|
|
12
libs/libfolly/patches/102-no-boost-thread.patch
Normal file
12
libs/libfolly/patches/102-no-boost-thread.patch
Normal file
|
@ -0,0 +1,12 @@
|
|||
diff --git a/CMake/folly-deps.cmake b/CMake/folly-deps.cmake
|
||||
index 0c212057..a4c06695 100644
|
||||
--- a/CMake/folly-deps.cmake
|
||||
+++ b/CMake/folly-deps.cmake
|
||||
@@ -12,7 +12,6 @@ find_package(Boost 1.51.0 MODULE
|
||||
program_options
|
||||
regex
|
||||
system
|
||||
- thread
|
||||
REQUIRED
|
||||
)
|
||||
list(APPEND FOLLY_LINK_LIBRARIES ${Boost_LIBRARIES})
|
|
@ -1,23 +0,0 @@
|
|||
--- a/folly/CachelinePadded.h
|
||||
+++ b/folly/CachelinePadded.h
|
||||
@@ -35,10 +35,6 @@ namespace folly {
|
||||
*/
|
||||
template <typename T>
|
||||
class CachelinePadded {
|
||||
- static_assert(
|
||||
- alignof(T) <= max_align_v,
|
||||
- "CachelinePadded does not support over-aligned types.");
|
||||
-
|
||||
public:
|
||||
template <typename... Args>
|
||||
explicit CachelinePadded(Args&&... args)
|
||||
--- a/folly/external/farmhash/farmhash.cpp
|
||||
+++ b/folly/external/farmhash/farmhash.cpp
|
||||
@@ -181,6 +181,7 @@
|
||||
|
||||
#undef bswap_32
|
||||
#undef bswap_64
|
||||
+#undef _BYTESWAP_H
|
||||
#include <byteswap.h>
|
||||
|
||||
#endif
|
Loading…
Reference in a new issue