openvswitch: bump to version 2.8.2
Changes since 2.8.2 as recorded in NEWS-2.8.2 - NSH implementation now conforms to latest draft (draft-ietf-sfc-nsh-28). - Bug fixes 0006-adapt-ovs-scripts.patch was splited into two separate patches as the original patch does not apply against 2.8.2 anymore. Other patches are just re-numbered without actual function change Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
This commit is contained in:
parent
450577536f
commit
fa958f4a99
8 changed files with 83 additions and 49 deletions
|
@ -12,15 +12,15 @@ include $(INCLUDE_DIR)/kernel.mk
|
|||
|
||||
PKG_NAME:=openvswitch
|
||||
|
||||
PKG_VERSION:=2.8.1
|
||||
PKG_RELEASE:=3
|
||||
PKG_VERSION:=2.8.2
|
||||
PKG_RELEASE:=1
|
||||
PKG_LICENSE:=Apache-2.0
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
PKG_USE_MIPS16:=0
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://www.openvswitch.org/releases/
|
||||
PKG_HASH:=8d1c439e26d7044f0ec823c7fef1b00b7c6465da0b83a7d0cf3191ed1dc43893
|
||||
PKG_HASH:=87b4a7e7134a44ce1f808d3415a2244b4518c2b0b2a42fa2f8231e592f13103d
|
||||
|
||||
PKG_BUILD_DEPENDS:=python/host python-six/host
|
||||
|
||||
|
|
|
@ -1,30 +0,0 @@
|
|||
diff --git a/utilities/ovs-ctl.in b/utilities/ovs-ctl.in
|
||||
index dc1d02c..61ecf2f 100755
|
||||
--- a/utilities/ovs-ctl.in
|
||||
+++ b/utilities/ovs-ctl.in
|
||||
@@ -108,7 +108,7 @@ set_system_ids () {
|
||||
esac
|
||||
set "$@" external-ids:system-id="\"$SYSTEM_ID\""
|
||||
|
||||
- set "$@" external-ids:hostname="\"$(hostname -f)\""
|
||||
+ set "$@" external-ids:hostname="\"$(cat /proc/sys/kernel/hostname)\""
|
||||
|
||||
set "$@" external-ids:rundir="\"$rundir\""
|
||||
|
||||
diff --git a/utilities/ovs-lib.in b/utilities/ovs-lib.in
|
||||
index 8665698..7931bc6 100644
|
||||
--- a/utilities/ovs-lib.in
|
||||
+++ b/utilities/ovs-lib.in
|
||||
@@ -157,7 +157,11 @@ install_dir () {
|
||||
[ "${OVS_USER##*:}" != "" ] && INSTALL_GROUP="${OVS_USER##*:}"
|
||||
|
||||
if test ! -d "$DIR"; then
|
||||
- install -d -m "$INSTALL_MODE" -o "$INSTALL_USER" -g "$INSTALL_GROUP" "$DIR"
|
||||
+ mkdir -p "$DIR"
|
||||
+ [ -n "$INSTALL_MODE" ] && chmod "$INSTALL_MODE" "$DIR"
|
||||
+ local OWN="$INSTALL_USER"
|
||||
+ [ -n "$OWN" ] && [ -n "$INSTALL_GROUP" ] && OWN="${OWN}:${INSTALL_GROUP}"
|
||||
+ [ -n "$OWN" ] && chown "$OWN" "$DIR"
|
||||
restorecon "$DIR" >/dev/null 2>&1
|
||||
fi
|
||||
}
|
|
@ -1,7 +1,7 @@
|
|||
From 12edcd800d924f69630768eeece842373dee5bb0 Mon Sep 17 00:00:00 2001
|
||||
From c27232c954cdbe0207252ad88fddad4fd6ac0fbc Mon Sep 17 00:00:00 2001
|
||||
From: Helmut Schaa <helmut.schaa@googlemail.com>
|
||||
Date: Wed, 8 Jan 2014 13:48:33 +0100
|
||||
Subject: [PATCH 1/2] netdev-linux: Use unsigned int for ifi_flags
|
||||
Subject: [PATCH 100/104] netdev-linux: Use unsigned int for ifi_flags
|
||||
|
||||
ifi_flags is unsigned, the local equivalents should do the same.
|
||||
|
||||
|
@ -11,10 +11,10 @@ Signed-off-by: Helmut Schaa <helmut.schaa@googlemail.com>
|
|||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/lib/netdev-linux.c b/lib/netdev-linux.c
|
||||
index 9bdbbdf..9eaac33 100644
|
||||
index c0471be15..0750e5f2c 100644
|
||||
--- a/lib/netdev-linux.c
|
||||
+++ b/lib/netdev-linux.c
|
||||
@@ -2709,7 +2709,7 @@ update_flags(struct netdev_linux *netdev, enum netdev_flags off,
|
||||
@@ -2788,7 +2788,7 @@ update_flags(struct netdev_linux *netdev, enum netdev_flags off,
|
||||
enum netdev_flags on, enum netdev_flags *old_flagsp)
|
||||
OVS_REQUIRES(netdev->mutex)
|
||||
{
|
||||
|
@ -24,5 +24,5 @@ index 9bdbbdf..9eaac33 100644
|
|||
|
||||
old_flags = netdev->ifi_flags;
|
||||
--
|
||||
1.8.1.4
|
||||
2.16.2
|
||||
|
|
@ -1,8 +1,8 @@
|
|||
From b9284f535e93c337ab21f330753e60e1038f9a27 Mon Sep 17 00:00:00 2001
|
||||
From a6df8dd455c8be7c0c2ba79f35cf5390e892b39e Mon Sep 17 00:00:00 2001
|
||||
From: Helmut Schaa <helmut.schaa@googlemail.com>
|
||||
Date: Wed, 8 Jan 2014 13:48:49 +0100
|
||||
Subject: [PATCH 2/2] netdev-linux: Let interface flag survive internal port
|
||||
setup
|
||||
Subject: [PATCH 101/104] netdev-linux: Let interface flag survive internal
|
||||
port setup
|
||||
|
||||
Due to a race condition when bringing up an internal port on Linux
|
||||
some interface flags (e.g. IFF_MULTICAST) are falsely reset. This
|
||||
|
@ -18,10 +18,10 @@ Signed-off-by: Helmut Schaa <helmut.schaa@googlemail.com>
|
|||
1 file changed, 7 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/lib/netdev-linux.c b/lib/netdev-linux.c
|
||||
index 9eaac33..423e72e 100644
|
||||
index 0750e5f2c..59e7b9c96 100644
|
||||
--- a/lib/netdev-linux.c
|
||||
+++ b/lib/netdev-linux.c
|
||||
@@ -2712,7 +2712,13 @@ update_flags(struct netdev_linux *netdev, enum netdev_flags off,
|
||||
@@ -2791,7 +2791,13 @@ update_flags(struct netdev_linux *netdev, enum netdev_flags off,
|
||||
unsigned int old_flags, new_flags;
|
||||
int error = 0;
|
||||
|
||||
|
@ -37,5 +37,5 @@ index 9eaac33..423e72e 100644
|
|||
new_flags = (old_flags & ~nd_to_iff_flags(off)) | nd_to_iff_flags(on);
|
||||
if (new_flags != old_flags) {
|
||||
--
|
||||
1.8.1.4
|
||||
2.16.2
|
||||
|
|
@ -1,7 +1,7 @@
|
|||
From dd52bf474a8c03a3b7a5d73229b64971d76adafd Mon Sep 17 00:00:00 2001
|
||||
From b3cc748d502f7f87aeb103b3f69573b0e640e2ba Mon Sep 17 00:00:00 2001
|
||||
From: Yousong Zhou <yszhou4tech@gmail.com>
|
||||
Date: Wed, 28 Feb 2018 13:42:44 +0800
|
||||
Subject: [PATCH] python: separate host/target python for cross-compile
|
||||
Subject: [PATCH 102/104] python: separate host/target python for cross-compile
|
||||
|
||||
At the moment, python-six is a requirement for openvswitch python
|
||||
library on target machine.
|
||||
|
@ -13,7 +13,7 @@ Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
|
|||
2 files changed, 5 insertions(+), 9 deletions(-)
|
||||
|
||||
diff --git a/Makefile.am b/Makefile.am
|
||||
index 31d6331..4b9e8d4 100644
|
||||
index 31d633179..4b9e8d491 100644
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -59,7 +59,7 @@ endif
|
||||
|
@ -26,7 +26,7 @@ index 31d6331..4b9e8d4 100644
|
|||
ALL_LOCAL =
|
||||
BUILT_SOURCES =
|
||||
diff --git a/m4/openvswitch.m4 b/m4/openvswitch.m4
|
||||
index 00ffad3..52f207b 100644
|
||||
index 00ffad35f..52f207bda 100644
|
||||
--- a/m4/openvswitch.m4
|
||||
+++ b/m4/openvswitch.m4
|
||||
@@ -347,20 +347,16 @@ else:
|
||||
|
@ -55,5 +55,5 @@ index 00ffad3..52f207b 100644
|
|||
dnl Checks for Python 3.x, x >= 4.
|
||||
AC_DEFUN([OVS_CHECK_PYTHON3],
|
||||
--
|
||||
1.8.3.1
|
||||
2.16.2
|
||||
|
|
@ -0,0 +1,33 @@
|
|||
From 05a6fa94778f9d6c54ca676de80708d03d6c365a Mon Sep 17 00:00:00 2001
|
||||
From: Yousong Zhou <yszhou4tech@gmail.com>
|
||||
Date: Wed, 14 Mar 2018 16:40:01 +0800
|
||||
Subject: [PATCH 103/104] ovs-ctl: fix setting hostname
|
||||
|
||||
The command "hostname" is not available in OpenWrt by default.
|
||||
|
||||
The other thing to note is that currently kernel.hostname is not a fully
|
||||
qualitied name
|
||||
|
||||
Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
|
||||
---
|
||||
utilities/ovs-ctl.in | 4 +---
|
||||
1 file changed, 1 insertion(+), 3 deletions(-)
|
||||
|
||||
diff --git a/utilities/ovs-ctl.in b/utilities/ovs-ctl.in
|
||||
index 4ddc450fb..52018e6d3 100755
|
||||
--- a/utilities/ovs-ctl.in
|
||||
+++ b/utilities/ovs-ctl.in
|
||||
@@ -68,9 +68,7 @@ ovs_vsctl () {
|
||||
}
|
||||
|
||||
set_hostname () {
|
||||
- # 'hostname -f' needs network connectivity to work. So we should
|
||||
- # call this only after ovs-vswitchd is running.
|
||||
- ovs_vsctl set Open_vSwitch . external-ids:hostname="$(hostname -f)"
|
||||
+ ovs_vsctl set Open_vSwitch . external-ids:hostname="$(sysctl -n kernel.hostname)"
|
||||
}
|
||||
|
||||
set_system_ids () {
|
||||
--
|
||||
2.16.2
|
||||
|
31
net/openvswitch/patches/0104-ovs-lib-fix-install_dir.patch
Normal file
31
net/openvswitch/patches/0104-ovs-lib-fix-install_dir.patch
Normal file
|
@ -0,0 +1,31 @@
|
|||
From d8dd661e1c100a2d2ba0361cf6c91dcdedfeeb70 Mon Sep 17 00:00:00 2001
|
||||
From: Yousong Zhou <yszhou4tech@gmail.com>
|
||||
Date: Wed, 14 Mar 2018 16:44:13 +0800
|
||||
Subject: [PATCH 104/104] ovs-lib: fix install_dir()
|
||||
|
||||
The command "install" is not available in OpenWrt by default
|
||||
|
||||
Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
|
||||
---
|
||||
utilities/ovs-lib.in | 5 ++++-
|
||||
1 file changed, 4 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/utilities/ovs-lib.in b/utilities/ovs-lib.in
|
||||
index 1bccea0c5..457297f3f 100644
|
||||
--- a/utilities/ovs-lib.in
|
||||
+++ b/utilities/ovs-lib.in
|
||||
@@ -157,7 +157,10 @@ install_dir () {
|
||||
[ "${OVS_USER##*:}" != "" ] && INSTALL_GROUP="${OVS_USER##*:}"
|
||||
|
||||
if test ! -d "$DIR"; then
|
||||
- install -d -m "$INSTALL_MODE" -o "$INSTALL_USER" -g "$INSTALL_GROUP" "$DIR"
|
||||
+ mkdir -p "$DIR"
|
||||
+ chmod "$INSTALL_MODE"
|
||||
+ chown "$INSTALL_USER" "$DIR"
|
||||
+ chgrp "$INSTALL_GROUP" "$DIR"
|
||||
restorecon "$DIR" >/dev/null 2>&1
|
||||
fi
|
||||
}
|
||||
--
|
||||
2.16.2
|
||||
|
Loading…
Reference in a new issue