gstreamer1: Update to 1.14.4
Disabled a bunch more stuff through the configure script. Refreshed patches. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
a694df10d5
commit
fa2ec95359
5 changed files with 70 additions and 72 deletions
|
@ -8,7 +8,7 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=gstreamer1
|
||||
PKG_VERSION:=1.14.2
|
||||
PKG_VERSION:=1.14.4
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org> \
|
||||
|
@ -19,8 +19,8 @@ PKG_LICENSE_FILES:=COPYING
|
|||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/gstreamer-$(PKG_VERSION)
|
||||
PKG_SOURCE:=gstreamer-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=http://gstreamer.freedesktop.org/src/gstreamer/
|
||||
PKG_HASH:=4bd6127299f3f29379046bbd58a526e6353b569e0e72f7b4df2ae70df6882e09
|
||||
PKG_SOURCE_URL:=https://gstreamer.freedesktop.org/src/gstreamer
|
||||
PKG_HASH:=f94f6696c5f05a3b3a9183e39c5f5c0b779f75a04c0efa497e7920afa985ffc7
|
||||
|
||||
PKG_FIXUP:=autoreconf
|
||||
PKG_REMOVE_FILES:=autogen.sh aclocal.m4
|
||||
|
@ -118,14 +118,18 @@ GST_VERSION:=1.0
|
|||
|
||||
CONFIGURE_ARGS += \
|
||||
--enable-static \
|
||||
--disable-benchmarks \
|
||||
--disable-examples \
|
||||
--disable-failing-tests \
|
||||
--disable-fatal-warnings \
|
||||
--disable-introspection \
|
||||
--disable-gst-tracer-hooks \
|
||||
--disable-gtk-doc-html \
|
||||
--disable-tests \
|
||||
--disable-valgrind \
|
||||
--disable-gst-tracer-hooks \
|
||||
--with-unwind=no \
|
||||
--without-libiconv-prefix \
|
||||
--without-libintl-prefix \
|
||||
--without-x \
|
||||
--without-unwind
|
||||
|
||||
EXTRA_LDFLAGS+= \
|
||||
-Wl,-rpath-link=$(STAGING_DIR)/usr/lib \
|
||||
|
|
|
@ -1,18 +1,6 @@
|
|||
diff -u --recursive gstreamer-1.12.4-vanilla/configure.ac gstreamer-1.12.4/configure.ac
|
||||
--- gstreamer-1.12.4-vanilla/configure.ac 2018-02-10 17:37:16.379378242 -0500
|
||||
+++ gstreamer-1.12.4/configure.ac 2018-02-10 17:40:18.742109326 -0500
|
||||
@@ -1083,7 +1083,6 @@
|
||||
plugins/Makefile
|
||||
plugins/elements/Makefile
|
||||
plugins/tracers/Makefile
|
||||
-po/Makefile.in
|
||||
tests/Makefile
|
||||
tests/benchmarks/Makefile
|
||||
tests/check/Makefile
|
||||
diff -u --recursive gstreamer-1.12.4-vanilla/Makefile.am gstreamer-1.12.4/Makefile.am
|
||||
--- gstreamer-1.12.4-vanilla/Makefile.am 2018-02-10 17:37:16.390378286 -0500
|
||||
+++ gstreamer-1.12.4/Makefile.am 2018-02-10 17:40:29.112150898 -0500
|
||||
@@ -9,7 +9,6 @@
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -9,7 +9,6 @@ aclocal_DATA = gst-element-check-1.0.m4
|
||||
SUBDIRS = pkgconfig \
|
||||
gst libs plugins tests \
|
||||
docs \
|
||||
|
@ -20,7 +8,7 @@ diff -u --recursive gstreamer-1.12.4-vanilla/Makefile.am gstreamer-1.12.4/Makefi
|
|||
m4 \
|
||||
common \
|
||||
data
|
||||
@@ -22,7 +21,6 @@
|
||||
@@ -22,7 +21,6 @@ endif
|
||||
DIST_SUBDIRS = pkgconfig \
|
||||
gst libs plugins tools tests \
|
||||
docs \
|
||||
|
@ -28,3 +16,13 @@ diff -u --recursive gstreamer-1.12.4-vanilla/Makefile.am gstreamer-1.12.4/Makefi
|
|||
m4 \
|
||||
common \
|
||||
data
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -1086,7 +1086,6 @@ libs/gst/net/Makefile
|
||||
plugins/Makefile
|
||||
plugins/elements/Makefile
|
||||
plugins/tracers/Makefile
|
||||
-po/Makefile.in
|
||||
tests/Makefile
|
||||
tests/benchmarks/Makefile
|
||||
tests/check/Makefile
|
||||
|
|
|
@ -1,7 +1,26 @@
|
|||
diff -u --recursive gstreamer-1.12.4-vanilla/configure.ac gstreamer-1.12.4/configure.ac
|
||||
--- gstreamer-1.12.4-vanilla/configure.ac 2018-02-10 17:43:59.957864211 -0500
|
||||
+++ gstreamer-1.12.4/configure.ac 2018-02-10 17:44:19.772930084 -0500
|
||||
@@ -1083,20 +1083,6 @@
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -7,7 +7,7 @@ aclocaldir = $(datadir)/aclocal
|
||||
aclocal_DATA = gst-element-check-1.0.m4
|
||||
|
||||
SUBDIRS = pkgconfig \
|
||||
- gst libs plugins tests \
|
||||
+ gst libs plugins \
|
||||
docs \
|
||||
m4 \
|
||||
common \
|
||||
@@ -19,7 +19,7 @@ endif
|
||||
|
||||
# These are all the possible subdirs
|
||||
DIST_SUBDIRS = pkgconfig \
|
||||
- gst libs plugins tools tests \
|
||||
+ gst libs plugins tools \
|
||||
docs \
|
||||
m4 \
|
||||
common \
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -1086,20 +1086,6 @@ libs/gst/net/Makefile
|
||||
plugins/Makefile
|
||||
plugins/elements/Makefile
|
||||
plugins/tracers/Makefile
|
||||
|
@ -22,24 +41,3 @@ diff -u --recursive gstreamer-1.12.4-vanilla/configure.ac gstreamer-1.12.4/confi
|
|||
tools/Makefile
|
||||
common/Makefile
|
||||
common/m4/Makefile
|
||||
diff -u --recursive gstreamer-1.12.4-vanilla/Makefile.am gstreamer-1.12.4/Makefile.am
|
||||
--- gstreamer-1.12.4-vanilla/Makefile.am 2018-02-10 17:43:59.959864217 -0500
|
||||
+++ gstreamer-1.12.4/Makefile.am 2018-02-10 17:44:30.298965075 -0500
|
||||
@@ -7,7 +7,7 @@
|
||||
aclocal_DATA = gst-element-check-@GST_API_VERSION@.m4
|
||||
|
||||
SUBDIRS = pkgconfig \
|
||||
- gst libs plugins tests \
|
||||
+ gst libs plugins \
|
||||
docs \
|
||||
m4 \
|
||||
common \
|
||||
@@ -19,7 +19,7 @@
|
||||
|
||||
# These are all the possible subdirs
|
||||
DIST_SUBDIRS = pkgconfig \
|
||||
- gst libs plugins tools tests \
|
||||
+ gst libs plugins tools \
|
||||
docs \
|
||||
m4 \
|
||||
common \
|
||||
|
|
|
@ -1,7 +1,24 @@
|
|||
diff -u --recursive gstreamer-1.12.4-vanilla/configure.ac gstreamer-1.12.4/configure.ac
|
||||
--- gstreamer-1.12.4-vanilla/configure.ac 2018-02-10 17:45:28.053157030 -0500
|
||||
+++ gstreamer-1.12.4/configure.ac 2018-02-10 17:45:47.703222322 -0500
|
||||
@@ -1086,12 +1086,6 @@
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -8,7 +8,6 @@ aclocal_DATA = gst-element-check-1.0.m4
|
||||
|
||||
SUBDIRS = pkgconfig \
|
||||
gst libs plugins \
|
||||
- docs \
|
||||
m4 \
|
||||
common \
|
||||
data
|
||||
@@ -20,7 +19,6 @@ endif
|
||||
# These are all the possible subdirs
|
||||
DIST_SUBDIRS = pkgconfig \
|
||||
gst libs plugins tools \
|
||||
- docs \
|
||||
m4 \
|
||||
common \
|
||||
data
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -1089,12 +1089,6 @@ plugins/tracers/Makefile
|
||||
tools/Makefile
|
||||
common/Makefile
|
||||
common/m4/Makefile
|
||||
|
@ -14,22 +31,3 @@ diff -u --recursive gstreamer-1.12.4-vanilla/configure.ac gstreamer-1.12.4/confi
|
|||
m4/Makefile
|
||||
pkgconfig/Makefile
|
||||
stamp.h
|
||||
diff -u --recursive gstreamer-1.12.4-vanilla/Makefile.am gstreamer-1.12.4/Makefile.am
|
||||
--- gstreamer-1.12.4-vanilla/Makefile.am 2018-02-10 17:45:28.053157030 -0500
|
||||
+++ gstreamer-1.12.4/Makefile.am 2018-02-10 17:45:58.940259656 -0500
|
||||
@@ -8,7 +8,6 @@
|
||||
|
||||
SUBDIRS = pkgconfig \
|
||||
gst libs plugins \
|
||||
- docs \
|
||||
m4 \
|
||||
common \
|
||||
data
|
||||
@@ -20,7 +19,6 @@
|
||||
# These are all the possible subdirs
|
||||
DIST_SUBDIRS = pkgconfig \
|
||||
gst libs plugins tools \
|
||||
- docs \
|
||||
m4 \
|
||||
common \
|
||||
data
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/gst/gstplugin.c
|
||||
+++ b/gst/gstplugin.c
|
||||
@@ -732,15 +732,8 @@ _priv_gst_plugin_load_file_for_registry
|
||||
@@ -776,15 +776,8 @@ _priv_gst_plugin_load_file_for_registry (const gchar * filename,
|
||||
goto return_error;
|
||||
}
|
||||
|
||||
|
|
Loading…
Reference in a new issue