gptfdisk: Update to 1.0.9
Backported an upstream commit to fix build with musl 1.2.4. Signed-off-by: Tianling Shen <cnsztl@immortalwrt.org>
This commit is contained in:
parent
b6d0e882dd
commit
fa2dce3b5b
2 changed files with 32 additions and 3 deletions
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=gptfdisk
|
||||
PKG_VERSION:=1.0.8
|
||||
PKG_RELEASE:=5
|
||||
PKG_VERSION:=1.0.9
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@SF/$(PKG_NAME)
|
||||
PKG_HASH:=95d19856f004dabc4b8c342b2612e8d0a9eebdd52004297188369f152e9dc6df
|
||||
PKG_HASH:=dafead2693faeb8e8b97832b23407f6ed5b3219bc1784f482dd855774e2d50c2
|
||||
|
||||
PKG_MAINTAINER:=
|
||||
PKG_LICENSE:=GPL-2.0-or-later
|
||||
|
|
|
@ -0,0 +1,29 @@
|
|||
From 7dfa8984f5a30f313d8675ff6097c8592d636d10 Mon Sep 17 00:00:00 2001
|
||||
From: Khem Raj <raj.khem@gmail.com>
|
||||
Date: Mon, 12 Dec 2022 12:50:07 -0800
|
||||
Subject: [PATCH] Use 64bit time_t on linux as well
|
||||
|
||||
Alias 64bit version of stat functions to original functions
|
||||
we are already passing -D_FILE_OFFSET_BITS=64 in linux Makefile
|
||||
|
||||
Signed-off-by: Khem Raj <raj.khem@gmail.com>
|
||||
---
|
||||
diskio-unix.cc | 6 +++++-
|
||||
1 file changed, 5 insertions(+), 1 deletion(-)
|
||||
|
||||
--- a/diskio-unix.cc
|
||||
+++ b/diskio-unix.cc
|
||||
@@ -37,8 +37,12 @@
|
||||
|
||||
using namespace std;
|
||||
|
||||
-#ifdef __APPLE__
|
||||
+#if defined(__APPLE__) || defined(__linux__)
|
||||
#define off64_t off_t
|
||||
+#define stat64 stat
|
||||
+#define fstat64 fstat
|
||||
+#define lstat64 lstat
|
||||
+#define lseek64 lseek
|
||||
#endif
|
||||
|
||||
// Returns the official "real" name for a shortened version of same.
|
Loading…
Reference in a new issue