Merge pull request #9881 from aparcar/ipsec-tools

remove ipsec-tools and opennhrp
This commit is contained in:
Rosen Penev 2019-09-01 11:34:33 -07:00 committed by GitHub
commit f9e5b9f143
No known key found for this signature in database
GPG key ID: 4AEE18F83AFDEB23
3 changed files with 0 additions and 95 deletions

View file

@ -1,60 +0,0 @@
#
# Copyright (C) 2009-2015 OpenWrt.org
# Copyright (C) 2009 Jakob Pfeiffer
# Copyright (C) 2014 Artem Makhutov
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=opennhrp
PKG_VERSION:=0.14.1
PKG_RELEASE:=2
PKG_MAINTAINER:=Artem Makhutov <artem@makhutov.org>
PKG_LICENSE:=MIT License
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=@SF/opennhrp
PKG_HASH:=1517d53d688ffc165a1da20c344d96b4c53e60f34bd73c64e60cb67cfca4e9ab
PKG_FIXUP:=autoreconf
PKG_BUILD_PARALLEL:=1
PKG_INSTALL:=1
include $(INCLUDE_DIR)/package.mk
define Package/opennhrp
SECTION:=net
CATEGORY:=Network
SUBMENU:=VPN
DEPENDS:=+libcares +ipsec-tools +ip +kmod-gre
KCONFIG:=CONFIG_ARPD=y
TITLE:=NBMA Next Hop Resolution Protocol
URL:=http://opennhrp.sourceforge.net/
endef
define Package/opennhrp/description
OpenNHRP implements NBMA Next Hop Resolution Protocol (as defined in RFC 2332).
It makes it possible to create dynamic multipoint VPN Linux router using NHRP,
GRE and IPsec. It aims to be Cisco DMVPN compatible.
endef
define Package/opennhrp/conffiles
/etc/opennhrp/opennhrp.conf
endef
define Package/opennhrp/install
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/opennhrp{,ctl} $(1)/usr/sbin/
$(INSTALL_DIR) $(1)/etc/opennhrp
$(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/opennhrp/opennhrp.conf $(1)/etc/opennhrp/
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/etc/opennhrp/opennhrp-script $(1)/etc/opennhrp/
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/etc/opennhrp/racoon-ph1down.sh $(1)/etc/opennhrp/
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/etc/opennhrp/racoon-ph1dead.sh $(1)/etc/opennhrp/
$(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_BIN) ./files/opennhrp.init $(1)/etc/init.d/opennhrp
endef
$(eval $(call BuildPackage,opennhrp))

View file

@ -1,15 +0,0 @@
#!/bin/sh /etc/rc.common
# Copyright (C) 2009-2011 OpenWrt.org
# Copyright (C) 2009 Jakob Pfeiffer
START=50
SERVICE_USE_PID=1
start() {
service_start /usr/sbin/opennhrp -d
}
stop() {
service_stop /usr/sbin/opennhrp
}

View file

@ -1,20 +0,0 @@
--- a/nhrp/opennhrp.c
+++ b/nhrp/opennhrp.c
@@ -9,6 +9,7 @@
#include <ctype.h>
#include <stdio.h>
#include <errno.h>
+#include <fcntl.h>
#include <malloc.h>
#include <stddef.h>
#include <string.h>
--- a/nhrp/nhrp_common.h
+++ b/nhrp/nhrp_common.h
@@ -12,6 +12,7 @@
#include <stdint.h>
#include <stdlib.h>
#include <sys/time.h>
+#include <sys/types.h>
#include <linux/if_ether.h>
struct nhrp_interface;