libmad: update to 0.16.2
Backport aarch64 patch. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
3f82f9a002
commit
f9813b3401
3 changed files with 29 additions and 12 deletions
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=libmad
|
||||
PKG_VERSION:=0.16.1
|
||||
PKG_VERSION:=0.16.2
|
||||
PKG_RELEASE:=$(AUTORELEASE)
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/tenacityteam/libmad/tar.gz/$(PKG_VERSION)?
|
||||
PKG_HASH:=3b716425cfab52d4c5127f45675a784f5c15d21b61d55850a49b2152c1bb108d
|
||||
PKG_HASH:=6c14c2f4dcf7fd32e447eef99d6c53faded52e22f95e223e6f58844030851b99
|
||||
|
||||
PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
|
||||
PKG_LICENSE:=GPL-2.0-or-later
|
||||
|
@ -21,6 +21,7 @@ PKG_LICENSE_FILES:=COPYING
|
|||
PKG_CPE_ID:=cpe:/a:underbit:mad_libmad
|
||||
|
||||
CMAKE_INSTALL:=1
|
||||
PKG_USE_MIPS16:=0
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include $(INCLUDE_DIR)/cmake.mk
|
||||
|
@ -39,6 +40,11 @@ define Package/libmad/description
|
|||
Layer I, Layer II, and Layer III (i.e. MP3) - are fully implemented.
|
||||
endef
|
||||
|
||||
CMAKE_OPTIONS += \
|
||||
-DOPTIMIZE=SPEED
|
||||
|
||||
TARGET_CFLAGS:= $(filter-out -O%,$(TARGET_CFLAGS)) -O2
|
||||
|
||||
define Package/libmad/install
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libmad.so.* $(1)/usr/lib/
|
||||
|
|
21
libs/libmad/patches/010-aarch64.patch
Normal file
21
libs/libmad/patches/010-aarch64.patch
Normal file
|
@ -0,0 +1,21 @@
|
|||
From 9ec2efa6ba4bfaed7805867077d3a67daa022331 Mon Sep 17 00:00:00 2001
|
||||
From: Daniel Engberg <daniel.engberg.lists@pyret.net>
|
||||
Date: Mon, 27 Jun 2022 01:58:45 +0200
|
||||
Subject: [PATCH] cmake: Add aarch64 as valid match for 64-bit (#5)
|
||||
|
||||
Allow aarch64 aka arm64 to use 64-bit fixed point math
|
||||
---
|
||||
CMakeLists.txt | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -78,7 +78,7 @@ elseif(CMAKE_SYSTEM_PROCESSOR MATCHES ".
|
||||
elseif(CMAKE_SYSTEM_PROCESSOR MATCHES ".(ppc|PPC).*")
|
||||
message(STATUS "Using PowerPC fixed point math")
|
||||
option(FPM_PPC "PowerPC fixed point math" ON)
|
||||
-elseif(CMAKE_SYSTEM_PROCESSOR MATCHES ".*(x86_64|x86-64|x64|AMD64|amd64).*")
|
||||
+elseif(CMAKE_SYSTEM_PROCESSOR MATCHES ".*(x86_64|x86-64|x64|AMD64|amd64|aarch64).*")
|
||||
message(STATUS "Using 64 bit fixed point math")
|
||||
option(FPM_64BIT "64 bit fixed point math" ON)
|
||||
else()
|
|
@ -1,10 +0,0 @@
|
|||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -62,6 +62,7 @@ elseif(CMAKE_SYSTEM_PROCESSOR MATCHES ".
|
||||
message(STATUS "Using ARM fixed point math")
|
||||
option (FPM_ARM "ARM fixed point math" ON)
|
||||
if(ASO)
|
||||
+ enable_language(ASM)
|
||||
target_compile_definitions(mad PRIVATE ASO_INTERLEAVE1 ASO_IMDCT)
|
||||
target_sources(mad PRIVATE imdct_l_arm.S)
|
||||
endif()
|
Loading…
Reference in a new issue