php7-pecl-http: update to 3.2.0
Drop already upstreamed patches. Signed-off-by: Michael Heimpold <mhei@heimpold.de>
This commit is contained in:
parent
010dc61d7b
commit
f8a7546537
4 changed files with 3 additions and 126 deletions
|
@ -8,9 +8,9 @@ include $(TOPDIR)/rules.mk
|
|||
PECL_NAME:=pecl_http
|
||||
PECL_LONGNAME:=Extended HTTP Support
|
||||
|
||||
PKG_VERSION:=3.1.0
|
||||
PKG_RELEASE:=5
|
||||
PKG_HASH:=e3de67b156e7d5f6c2e5eb1e2b5f0acceb7004f1260d68c9f8b2c0f9629aabf0
|
||||
PKG_VERSION:=3.2.0
|
||||
PKG_RELEASE:=1
|
||||
PKG_HASH:=6fb7f038365fb1f3302f1b7e7d6b55d5c422bdea36057b1efe02bbe6ad3cc01b
|
||||
|
||||
PKG_NAME:=php7-pecl-http
|
||||
PKG_SOURCE:=$(PECL_NAME)-$(PKG_VERSION).tgz
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- a/src/php_http_etag.c 2016-12-12 10:04:21.000000000 +0100
|
||||
+++ b/src/php_http_etag.c 2016-12-23 21:10:59.523222367 +0100
|
||||
@@ -60,7 +60,7 @@
|
||||
unsigned char buf[4];
|
||||
|
||||
*((uint *) e->ctx) = ~*((uint *) e->ctx);
|
||||
-#if WORDS_BIGENDIAN
|
||||
+#ifdef WORDS_BIGENDIAN
|
||||
etag = php_http_etag_digest((unsigned char *) e->ctx, 4);
|
||||
#else
|
||||
buf[0] = ((unsigned char *) e->ctx)[3];
|
|
@ -1,57 +0,0 @@
|
|||
From ab5b4e3acd2b0379e5d8bc95a8d4f83ce5c91fb7 Mon Sep 17 00:00:00 2001
|
||||
From: Michael Heimpold <mhei@heimpold.de>
|
||||
Date: Sun, 4 Jun 2017 15:00:33 +0200
|
||||
Subject: [PATCH] Handle NULL strings gracefully during constant registration
|
||||
|
||||
When libcurl is compiled not using e.g. libz or SSL, then a call to
|
||||
curl_version_info could return NULL in the corresponding fields of
|
||||
curl_version_info_data.
|
||||
|
||||
Passing such NULL pointers down to REGISTER_NS_STRING_CONSTANT results
|
||||
in a segfault during php startup, so let's check for this special case
|
||||
and register a NULL constant in this case.
|
||||
|
||||
Signed-off-by: Michael Heimpold <mhei@heimpold.de>
|
||||
---
|
||||
src/php_http_client_curl.c | 16 ++++++++++++----
|
||||
1 file changed, 12 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/src/php_http_client_curl.c b/src/php_http_client_curl.c
|
||||
index f286324..f07bb8f 100644
|
||||
--- a/src/php_http_client_curl.c
|
||||
+++ b/src/php_http_client_curl.c
|
||||
@@ -2429,6 +2429,14 @@ php_http_client_ops_t *php_http_client_curl_get_ops(void)
|
||||
return &php_http_client_curl_ops;
|
||||
}
|
||||
|
||||
+#define REGISTER_NS_STRING_OR_NULL_CONSTANT(ns, name, str, flags) \
|
||||
+ do { \
|
||||
+ if ((str) != NULL) { \
|
||||
+ REGISTER_NS_STRING_CONSTANT(ns, name, str, flags); \
|
||||
+ } else { \
|
||||
+ REGISTER_NS_NULL_CONSTANT(ns, name, flags); \
|
||||
+ } \
|
||||
+ } while (0)
|
||||
|
||||
PHP_MINIT_FUNCTION(http_client_curl)
|
||||
{
|
||||
@@ -2509,12 +2517,12 @@ PHP_MINIT_FUNCTION(http_client_curl)
|
||||
REGISTER_NS_STRING_CONSTANT("http\\Client\\Curl", "VERSIONS", curl_version(), CONST_CS|CONST_PERSISTENT);
|
||||
#if CURLVERSION_NOW >= 0
|
||||
REGISTER_NS_STRING_CONSTANT("http\\Client\\Curl\\Versions", "CURL", (char *) info->version, CONST_CS|CONST_PERSISTENT);
|
||||
- REGISTER_NS_STRING_CONSTANT("http\\Client\\Curl\\Versions", "SSL", (char *) info->ssl_version, CONST_CS|CONST_PERSISTENT);
|
||||
- REGISTER_NS_STRING_CONSTANT("http\\Client\\Curl\\Versions", "LIBZ", (char *) info->libz_version, CONST_CS|CONST_PERSISTENT);
|
||||
+ REGISTER_NS_STRING_OR_NULL_CONSTANT("http\\Client\\Curl\\Versions", "SSL", (char *) info->ssl_version, CONST_CS|CONST_PERSISTENT);
|
||||
+ REGISTER_NS_STRING_OR_NULL_CONSTANT("http\\Client\\Curl\\Versions", "LIBZ", (char *) info->libz_version, CONST_CS|CONST_PERSISTENT);
|
||||
# if CURLVERSION_NOW >= 1
|
||||
- REGISTER_NS_STRING_CONSTANT("http\\Client\\Curl\\Versions", "ARES", (char *) info->ares, CONST_CS|CONST_PERSISTENT);
|
||||
+ REGISTER_NS_STRING_OR_NULL_CONSTANT("http\\Client\\Curl\\Versions", "ARES", (char *) info->ares, CONST_CS|CONST_PERSISTENT);
|
||||
# if CURLVERSION_NOW >= 2
|
||||
- REGISTER_NS_STRING_CONSTANT("http\\Client\\Curl\\Versions", "IDN", (char *) info->libidn, CONST_CS|CONST_PERSISTENT);
|
||||
+ REGISTER_NS_STRING_OR_NULL_CONSTANT("http\\Client\\Curl\\Versions", "IDN", (char *) info->libidn, CONST_CS|CONST_PERSISTENT);
|
||||
# endif
|
||||
# endif
|
||||
#endif
|
||||
--
|
||||
2.7.4
|
||||
|
|
@ -1,55 +0,0 @@
|
|||
From 8158548a80733b3af9539356b47527d960a13287 Mon Sep 17 00:00:00 2001
|
||||
From: Michael Wallner <mike@php.net>
|
||||
Date: Thu, 1 Feb 2018 14:36:09 +0100
|
||||
Subject: [PATCH] fix #73
|
||||
|
||||
include idna.h prior idn2.h to ensure INDA_H is defined and libidn2 does
|
||||
not try to define the idna compat layer
|
||||
---
|
||||
src/php_http.c | 6 +++---
|
||||
src/php_http_url.c | 6 +++---
|
||||
2 files changed, 6 insertions(+), 6 deletions(-)
|
||||
|
||||
diff --git a/src/php_http.c b/src/php_http.c
|
||||
index 207c248..bc9166a 100644
|
||||
--- a/src/php_http.c
|
||||
+++ b/src/php_http.c
|
||||
@@ -31,12 +31,12 @@
|
||||
#if PHP_HTTP_HAVE_LIBICU
|
||||
# include <unicode/uversion.h>
|
||||
#endif
|
||||
-#if PHP_HTTP_HAVE_LIBIDN2
|
||||
-# include <idn2.h>
|
||||
-#endif
|
||||
#if PHP_HTTP_HAVE_LIBIDN
|
||||
# include <idna.h>
|
||||
#endif
|
||||
+#if PHP_HTTP_HAVE_LIBIDN2
|
||||
+# include <idn2.h>
|
||||
+#endif
|
||||
#if PHP_HTTP_HAVE_LIBIDNKIT2 || PHP_HTTP_HAVE_LIBIDNKIT
|
||||
#include "idn/version.h"
|
||||
#endif
|
||||
diff --git a/src/php_http_url.c b/src/php_http_url.c
|
||||
index 029e6a8..361e61c 100644
|
||||
--- a/src/php_http_url.c
|
||||
+++ b/src/php_http_url.c
|
||||
@@ -12,12 +12,12 @@
|
||||
|
||||
#include "php_http_api.h"
|
||||
|
||||
-#if PHP_HTTP_HAVE_LIBIDN2
|
||||
-# include <idn2.h>
|
||||
-#endif
|
||||
#if PHP_HTTP_HAVE_LIBIDN
|
||||
# include <idna.h>
|
||||
#endif
|
||||
+#if PHP_HTTP_HAVE_LIBIDN2
|
||||
+# include <idn2.h>
|
||||
+#endif
|
||||
#if PHP_HTTP_HAVE_LIBICU
|
||||
# include <unicode/uidna.h>
|
||||
#endif
|
||||
--
|
||||
2.7.4
|
||||
|
Loading…
Reference in a new issue