Merge pull request #10236 from jefferyto/gammu-fix-lib-symlinks-openwrt-19.07
[openwrt-19.07] gammu: Fix lib symlinks
This commit is contained in:
commit
f745880429
2 changed files with 6 additions and 22 deletions
|
@ -9,19 +9,19 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=gammu
|
||||
PKG_VERSION:=1.40.0
|
||||
PKG_RELEASE:=1
|
||||
PKG_VERSION:=1.41.0
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=https://dl.cihar.com/gammu/releases
|
||||
PKG_HASH:=a760a3520d9f3a16a4ed73cefaabdbd86125bec73c6fa056ca3f0a4be8478dd6
|
||||
PKG_HASH:=8426b69b07b259de301f41163fab5587935e27b94cc5eefab9277773b3e4df8f
|
||||
|
||||
PKG_MAINTAINER:=Vitaly Protsko <villy@sft.ru>
|
||||
PKG_LICENCE:=GPL-2.0-or-later
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
CMAKE_INSTALL:=1
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include $(INCLUDE_DIR)/nls.mk
|
||||
|
@ -33,7 +33,7 @@ define Package/gammu
|
|||
TITLE:=Cell phone/modem SMS and control tool
|
||||
URL:=https://wammu.eu/gammu/
|
||||
DEPENDS:=+libpthread +libcurl +glib2 $(ICONV_DEPENDS) $(INTL_DEPENDS)
|
||||
DEPENDS+=+PACKAGE_python:python +PACKAGE_bluez-libs:bluez-libs
|
||||
DEPENDS+=+PACKAGE_bluez-libs:bluez-libs
|
||||
DEPENDS+=+PACKAGE_libmariadb:libmariadb +PACKAGE_unixodbc:unixodbc +PACKAGE_libpq:libpq
|
||||
DEPENDS+=+PACKAGE_libusb-1.0:libusb-1.0
|
||||
endef
|
||||
|
@ -54,7 +54,7 @@ define Package/gammu/install
|
|||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/gammu $(1)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/gammu-{smsd,smsd-inject,smsd-monitor} $(1)/usr/bin
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/lib{Gammu*,gsmsd*} $(1)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{Gammu*,gsmsd*} $(1)/usr/lib
|
||||
$(INSTALL_DIR) $(1)/etc/init.d
|
||||
$(INSTALL_DIR) $(1)/etc/config
|
||||
$(INSTALL_CONF) ./files/gammu $(1)/etc/config/gammu
|
||||
|
|
|
@ -1,16 +0,0 @@
|
|||
--- a/utils/gammu-config
|
||||
+++ b/utils/gammu-config
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/bin/bash
|
||||
+#!/bin/sh
|
||||
# Gammu configuration generator
|
||||
# Copyright (C) 2003 - 2009 Michal Cihar <michal@cihar.com>
|
||||
# vim: expandtab sw=4 ts=4 sts=4:
|
||||
--- a/utils/jadmaker
|
||||
+++ b/utils/jadmaker
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/bin/bash
|
||||
+#!/bin/sh
|
||||
# JAD file generator
|
||||
# Copyright © 2008 - 2009 Michal Čihař <michal@cihar.com>
|
||||
# vim: expandtab sw=4 ts=4 sts=4:
|
Loading…
Reference in a new issue