smartmontools: package a script for sending email notifications
A separate package which depdens on msmtp and nail is introduced. Once more packages provide `sendmail` and `mail` interfaces, this dependency can be made more flexible. Signed-off-by: Maxim Storchak <m.storchak@gmail.com>
This commit is contained in:
parent
1ab383fb71
commit
f5f49e48fe
2 changed files with 31 additions and 1 deletions
|
@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/uclibc++.mk
|
||||||
|
|
||||||
PKG_NAME:=smartmontools
|
PKG_NAME:=smartmontools
|
||||||
PKG_VERSION:=7.1
|
PKG_VERSION:=7.1
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=2
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=@SF/smartmontools
|
PKG_SOURCE_URL:=@SF/smartmontools
|
||||||
|
@ -68,6 +68,17 @@ define Package/smartmontools-drivedb/description
|
||||||
Database of known drives and USB bridges for smartctl and smartd.
|
Database of known drives and USB bridges for smartctl and smartd.
|
||||||
endef
|
endef
|
||||||
|
|
||||||
|
define Package/smartd-mail
|
||||||
|
$(call Package/smartmontools/Default)
|
||||||
|
TITLE+= Email notifications
|
||||||
|
PKGARCH=all
|
||||||
|
DEPENDS+= +smartd, +nail, +msmtp-mta
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/smartd-mail/description
|
||||||
|
A script for mailing about SMART issues
|
||||||
|
endef
|
||||||
|
|
||||||
ifeq ($(CONFIG_USE_UCLIBCXX),y)
|
ifeq ($(CONFIG_USE_UCLIBCXX),y)
|
||||||
TARGET_LDFLAGS +=-nodefaultlibs
|
TARGET_LDFLAGS +=-nodefaultlibs
|
||||||
else
|
else
|
||||||
|
@ -110,6 +121,11 @@ define Package/smartmontools-drivedb/install
|
||||||
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/smartmontools/drivedb.h $(1)/usr/share/smartmontools/
|
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/smartmontools/drivedb.h $(1)/usr/share/smartmontools/
|
||||||
endef
|
endef
|
||||||
|
|
||||||
|
define Package/smartd-mail/install
|
||||||
|
$(INSTALL_DIR) $(1)/etc
|
||||||
|
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/etc/smartd_warning.sh $(1)/etc
|
||||||
|
endef
|
||||||
|
|
||||||
define Package/smartd/conffiles
|
define Package/smartd/conffiles
|
||||||
/etc/smartd.conf
|
/etc/smartd.conf
|
||||||
endef
|
endef
|
||||||
|
@ -117,3 +133,4 @@ endef
|
||||||
$(eval $(call BuildPackage,smartmontools))
|
$(eval $(call BuildPackage,smartmontools))
|
||||||
$(eval $(call BuildPackage,smartd))
|
$(eval $(call BuildPackage,smartd))
|
||||||
$(eval $(call BuildPackage,smartmontools-drivedb))
|
$(eval $(call BuildPackage,smartmontools-drivedb))
|
||||||
|
$(eval $(call BuildPackage,smartd-mail))
|
||||||
|
|
13
utils/smartmontools/patches/002-os_mailer-is-mailx.patch
Normal file
13
utils/smartmontools/patches/002-os_mailer-is-mailx.patch
Normal file
|
@ -0,0 +1,13 @@
|
||||||
|
diff --git a/configure b/configure
|
||||||
|
index 6f442b3..5803c83 100755
|
||||||
|
--- a/configure
|
||||||
|
+++ b/configure
|
||||||
|
@@ -6988,7 +6988,7 @@ releaseversion='${PACKAGE}-${VERSION}'
|
||||||
|
# Set platform-specific modules and symbols
|
||||||
|
os_libs=
|
||||||
|
os_dltools='curl wget lynx svn'
|
||||||
|
-os_mailer=mail
|
||||||
|
+os_mailer=mailx
|
||||||
|
os_hostname="'hostname'"
|
||||||
|
os_dnsdomainname=
|
||||||
|
os_nisdomainname="'domainname'"
|
Loading…
Reference in a new issue