commit
f5586e11cb
2 changed files with 3 additions and 50 deletions
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=motion
|
||||
PKG_VERSION:=4.3.1
|
||||
PKG_RELEASE:=4
|
||||
PKG_VERSION:=4.3.2
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-release-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/Motion-Project/motion/tar.gz/release-$(PKG_VERSION)?
|
||||
PKG_HASH:=545712b10fc4a0134e994b7d8a3773c1c22f0bf4bd7afea7d7ffff357aca9ea5
|
||||
PKG_HASH:=dafa4264b2d8e4778f8be5871f09b6c0ec710d5a836182c583469c18db944d70
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-release-$(PKG_VERSION)
|
||||
|
||||
PKG_MAINTAINER:=Roger D <rogerdammit@gmail.com>
|
||||
|
|
|
@ -1,47 +0,0 @@
|
|||
--- a/src/webu.c
|
||||
+++ b/src/webu.c
|
||||
@@ -1203,7 +1203,7 @@ static void webu_answer_strm_type(struct webui_ctx *webui) {
|
||||
|
||||
}
|
||||
|
||||
-static int webu_answer_ctrl(void *cls
|
||||
+static enum MHD_Result webu_answer_ctrl(void *cls
|
||||
, struct MHD_Connection *connection
|
||||
, const char *url
|
||||
, const char *method
|
||||
@@ -1213,7 +1213,7 @@ static int webu_answer_ctrl(void *cls
|
||||
, void **ptr) {
|
||||
|
||||
/* This function "answers" the request for a webcontrol.*/
|
||||
- int retcd;
|
||||
+ enum MHD_Result retcd;
|
||||
struct webui_ctx *webui = *ptr;
|
||||
|
||||
/* Eliminate compiler warnings */
|
||||
@@ -1275,7 +1275,7 @@ static int webu_answer_ctrl(void *cls
|
||||
|
||||
}
|
||||
|
||||
-static int webu_answer_strm(void *cls
|
||||
+static enum MHD_Result webu_answer_strm(void *cls
|
||||
, struct MHD_Connection *connection
|
||||
, const char *url
|
||||
, const char *method
|
||||
@@ -1285,7 +1285,7 @@ static int webu_answer_strm(void *cls
|
||||
, void **ptr) {
|
||||
|
||||
/* Answer the request for all the streams*/
|
||||
- int retcd;
|
||||
+ enum MHD_Result retcd;
|
||||
struct webui_ctx *webui = *ptr;
|
||||
|
||||
/* Eliminate compiler warnings */
|
||||
@@ -1484,7 +1484,7 @@ static void webu_mhd_features_basic(struct mhdstart_ctx *mhdst){
|
||||
#if MHD_VERSION < 0x00094400
|
||||
(void)mhdst;
|
||||
#else
|
||||
- int retcd;
|
||||
+ enum MHD_Result retcd;
|
||||
retcd = MHD_is_feature_supported (MHD_FEATURE_BASIC_AUTH);
|
||||
if (retcd == MHD_YES){
|
||||
MOTION_LOG(DBG, TYPE_STREAM, NO_ERRNO ,_("Basic authentication: available"));
|
Loading…
Reference in a new issue