kea: Update to 2.2.0

Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
This commit is contained in:
Philip Prindeville 2023-04-18 18:21:29 -06:00 committed by Rosen Penev
parent 2fed4c0895
commit f544e95099
4 changed files with 8 additions and 16 deletions

View file

@ -9,14 +9,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=kea
PKG_VERSION:=2.0.3
PKG_RELEASE:=2
PKG_VERSION:=2.2.0
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://ftp.isc.org/isc/kea/$(PKG_VERSION)
PKG_HASH:=d642907374d17480ebe4df805b363dc9e230a955475a9f3e04a076b52d5c43ec
PKG_HASH:=da7d90ca62a772602dac6e77e507319038422895ad68eeb142f1487d67d531d2
PKG_MAINTAINER:=BangLang Huang<banglang.huang@foxmail.com>, Rosy Song<rosysong@rosinson.com>
PKG_MAINTAINER:=BangLang Huang <banglang.huang@foxmail.com>, Rosy Song <rosysong@rosinson.com>
PKG_LICENSE:=MPL-2.0
PKG_LICENSE_FILES:=COPYING

View file

@ -158,14 +158,6 @@
AM_CPPFLAGS = -I$(top_srcdir)/src/lib -I$(top_builddir)/src/lib
AM_CPPFLAGS += $(BOOST_INCLUDES)
--- a/src/lib/cql/Makefile.am
+++ b/src/lib/cql/Makefile.am
@@ -1,4 +1,4 @@
-SUBDIRS = . testutils tests
+SUBDIRS = .
AM_CPPFLAGS = -I$(top_srcdir)/src/lib -I$(top_builddir)/src/lib
AM_CPPFLAGS += $(BOOST_INCLUDES) $(CQL_CPPFLAGS)
--- a/src/lib/cryptolink/Makefile.am
+++ b/src/lib/cryptolink/Makefile.am
@@ -1,4 +1,4 @@
@ -203,8 +195,8 @@
@@ -1,6 +1,6 @@
AUTOMAKE_OPTIONS = subdir-objects
-SUBDIRS = . testutils tests benchmarks
+SUBDIRS = . benchmarks
-SUBDIRS = . testutils tests
+SUBDIRS = .
# DATA_DIR is the directory where to put default CSV files and the DHCPv6
# server ID file (i.e. the file where the server finds its DUID at startup).

View file

@ -1,6 +1,6 @@
--- a/src/bin/keactrl/keactrl.in
+++ b/src/bin/keactrl/keactrl.in
@@ -117,7 +117,7 @@ get_pid_from_file() {
@@ -115,7 +115,7 @@ get_pid_from_file() {
# Extract the name portion (from last slash to last dot) of the config file name
# File name and extension are documented in src/lib/util/filename.h
local conf_name

View file

@ -1,6 +1,6 @@
--- a/src/lib/cryptolink/openssl_link.cc
+++ b/src/lib/cryptolink/openssl_link.cc
@@ -79,7 +79,7 @@ CryptoLink::initialize() {
@@ -77,7 +77,7 @@ CryptoLink::initialize(CryptoLink& c) {
std::string
CryptoLink::getVersion() {