perl-www-curl: add patch to ensure compatibility with curl 7.88
Patch comes from https://github.com/openwrt/packages/pull/20540#issuecomment-1439537287 Fixes: /home/username/works/openwrt/staging_dir/target-x86_64_glibc_custom/usr/include/curl/curl.h:2515:3: note: declared here 2515 | CURLFORM_CONTENTTYPE CURL_DEPRECATED(7.56.0, "Use curl_mime_type()"), | ^~~~~~~~~~~~~~~~~~~~ make[3]: *** [Makefile:347: Curl.o] Error 1 Signed-off-by: Stan Grishin <stangri@melmac.ca>
This commit is contained in:
parent
3371071730
commit
f51a784a83
1 changed files with 11 additions and 0 deletions
11
lang/perl-www-curl/patches/230-curl_7.88_compat.patch
Normal file
11
lang/perl-www-curl/patches/230-curl_7.88_compat.patch
Normal file
|
@ -0,0 +1,11 @@
|
||||||
|
--- a/Makefile.PL
|
||||||
|
+++ b/Makefile.PL
|
||||||
|
@@ -127,7 +127,7 @@ if (!defined($curl_h)) {
|
||||||
|
close H;
|
||||||
|
|
||||||
|
for my $e (sort @syms) {
|
||||||
|
- if($e =~ /(OBSOLETE|^CURL_EXTERN|CURLOPT\z|^CURL_STRICTER\z|_LAST\z|_LASTENTRY\z|WIN32)/) {
|
||||||
|
+ if($e =~ /(OBSOLETE|^CURL_EXTERN|^CURL_STRICTER\z|^CURL_DID_MEMORY_FUNC_TYPEDEFS\z|_LAST\z|_LASTENTRY\z|^CURLINC_|^CURL_WIN32\z|^CURL_DEPRECATED\z|^CURL_IGNORE_DEPRECATION\z|^CURLOPTDEPRECATED\z|^CURLOPT\z)/) {
|
||||||
|
next;
|
||||||
|
}
|
||||||
|
my ($group) = $e =~ m/^([^_]+_)/;
|
Loading…
Reference in a new issue