Revert "python: add patch to abort build on failed module build"
This commit is contained in:
parent
10313e98af
commit
f4e9c703b3
1 changed files with 0 additions and 21 deletions
|
@ -1,21 +0,0 @@
|
||||||
Abort on failed module build
|
|
||||||
|
|
||||||
When building a Python module fails, the setup.py script currently
|
|
||||||
doesn't exit with an error, and simply continues. This is not a really
|
|
||||||
nice behavior, so this patch changes setup.py to abort with an error,
|
|
||||||
so that the build issue is clearly noticeable.
|
|
||||||
|
|
||||||
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
||||||
|
|
||||||
Index: b/setup.py
|
|
||||||
===================================================================
|
|
||||||
--- a/setup.py
|
|
||||||
+++ b/setup.py
|
|
||||||
@@ -283,6 +283,7 @@
|
|
||||||
print "Failed to build these modules:"
|
|
||||||
print_three_column(failed)
|
|
||||||
print
|
|
||||||
+ sys.exit(1)
|
|
||||||
|
|
||||||
def build_extension(self, ext):
|
|
||||||
|
|
Loading…
Reference in a new issue