lvm2: update source, refresh patch
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
This commit is contained in:
parent
34abdc2f6f
commit
f4816e2ba1
2 changed files with 7 additions and 7 deletions
|
@ -9,13 +9,13 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=LVM2
|
PKG_NAME:=LVM2
|
||||||
PKG_VERSION:=2.02.125
|
PKG_VERSION:=2.02.126
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
PKG_LICENSE:=GPL-2.0 LGPL-2.1
|
PKG_LICENSE:=GPL-2.0 LGPL-2.1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME).$(PKG_VERSION).tgz
|
PKG_SOURCE:=$(PKG_NAME).$(PKG_VERSION).tgz
|
||||||
PKG_SOURCE_URL:=ftp://sources.redhat.com/pub/lvm2
|
PKG_SOURCE_URL:=ftp://sources.redhat.com/pub/lvm2
|
||||||
PKG_MD5SUM:=2d24ba982c8a85e8c837210f087a6a51
|
PKG_MD5SUM:=38cd1953b62bd256c9e924adee01e995
|
||||||
PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
|
PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
|
||||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME).$(PKG_VERSION)
|
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME).$(PKG_VERSION)
|
||||||
|
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/lib/commands/toolcontext.c
|
--- a/lib/commands/toolcontext.c
|
||||||
+++ b/lib/commands/toolcontext.c
|
+++ b/lib/commands/toolcontext.c
|
||||||
@@ -1690,8 +1690,10 @@ struct cmd_context *create_toolcontext(u
|
@@ -1686,8 +1686,10 @@ struct cmd_context *create_toolcontext(u
|
||||||
unsigned threaded)
|
unsigned threaded)
|
||||||
{
|
{
|
||||||
struct cmd_context *cmd;
|
struct cmd_context *cmd;
|
||||||
|
@ -11,7 +11,7 @@
|
||||||
|
|
||||||
#ifdef M_MMAP_MAX
|
#ifdef M_MMAP_MAX
|
||||||
mallopt(M_MMAP_MAX, 0);
|
mallopt(M_MMAP_MAX, 0);
|
||||||
@@ -1727,7 +1729,7 @@ struct cmd_context *create_toolcontext(u
|
@@ -1723,7 +1725,7 @@ struct cmd_context *create_toolcontext(u
|
||||||
/* FIXME Make this configurable? */
|
/* FIXME Make this configurable? */
|
||||||
reset_lvm_errno(1);
|
reset_lvm_errno(1);
|
||||||
|
|
||||||
|
@ -20,7 +20,7 @@
|
||||||
/* Set in/out stream buffering before glibc */
|
/* Set in/out stream buffering before glibc */
|
||||||
if (set_buffering) {
|
if (set_buffering) {
|
||||||
/* Allocate 2 buffers */
|
/* Allocate 2 buffers */
|
||||||
@@ -2100,7 +2102,7 @@ void destroy_toolcontext(struct cmd_cont
|
@@ -2096,7 +2098,7 @@ void destroy_toolcontext(struct cmd_cont
|
||||||
if (cmd->libmem)
|
if (cmd->libmem)
|
||||||
dm_pool_destroy(cmd->libmem);
|
dm_pool_destroy(cmd->libmem);
|
||||||
|
|
||||||
|
@ -31,7 +31,7 @@
|
||||||
if (is_valid_fd(STDIN_FILENO) &&
|
if (is_valid_fd(STDIN_FILENO) &&
|
||||||
--- a/tools/lvmcmdline.c
|
--- a/tools/lvmcmdline.c
|
||||||
+++ b/tools/lvmcmdline.c
|
+++ b/tools/lvmcmdline.c
|
||||||
@@ -1689,6 +1689,7 @@ int lvm_split(char *str, int *argc, char
|
@@ -1722,6 +1722,7 @@ int lvm_split(char *str, int *argc, char
|
||||||
/* Make sure we have always valid filedescriptors 0,1,2 */
|
/* Make sure we have always valid filedescriptors 0,1,2 */
|
||||||
static int _check_standard_fds(void)
|
static int _check_standard_fds(void)
|
||||||
{
|
{
|
||||||
|
@ -39,7 +39,7 @@
|
||||||
int err = is_valid_fd(STDERR_FILENO);
|
int err = is_valid_fd(STDERR_FILENO);
|
||||||
|
|
||||||
if (!is_valid_fd(STDIN_FILENO) &&
|
if (!is_valid_fd(STDIN_FILENO) &&
|
||||||
@@ -1715,6 +1716,12 @@ static int _check_standard_fds(void)
|
@@ -1748,6 +1749,12 @@ static int _check_standard_fds(void)
|
||||||
strerror(errno));
|
strerror(errno));
|
||||||
return 0;
|
return 0;
|
||||||
}
|
}
|
||||||
|
|
Loading…
Reference in a new issue