commit
f4402d4770
2 changed files with 7 additions and 33 deletions
|
@ -8,17 +8,18 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=fio
|
||||
PKG_VERSION:=3.13
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=3.14
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE_URL:=http://brick.kernel.dk/snaps
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_HASH:=a21d1e50c18eecbd5ee6f7c3c0a8c8605bbe31b91e07c387b2144b02ea3fb235
|
||||
PKG_HASH:=1b4ce680242725df2fd3cca76047a4ebf07ed9034e2fa733ebb65ae8ed28fe10
|
||||
|
||||
PKG_MAINTAINER:=Rosen Penev <rosenp@gmail.com>
|
||||
PKG_LICENSE:=GPL-2.0+
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
|
||||
PKG_INSTALL:=1
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
@ -53,11 +54,12 @@ CONFIGURE_ARGS = \
|
|||
--disable-pmem \
|
||||
--disable-native \
|
||||
--cc="$(TARGET_CC)" \
|
||||
--extra-cflags="$(TARGET_CFLAGS)"
|
||||
--extra-cflags="$(TARGET_CFLAGS)" \
|
||||
--prefix="$(CONFIGURE_PREFIX)"
|
||||
|
||||
define Package/fio/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/fio $(1)/usr/bin/
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/fio $(1)/usr/bin/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,fio))
|
||||
|
|
|
@ -1,28 +0,0 @@
|
|||
From ec4b65d9c9180101807f598c9edecb462f54261a Mon Sep 17 00:00:00 2001
|
||||
From: Rosen Penev <rosenp@gmail.com>
|
||||
Date: Sun, 31 Mar 2019 21:19:03 -0700
|
||||
Subject: [PATCH] arch: fix build breakage on armv6 again
|
||||
|
||||
6K was missing from the defines.
|
||||
|
||||
Signed-off-by: Rosen Penev <rosenp@gmail.com>
|
||||
---
|
||||
arch/arch-arm.h | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/arch/arch-arm.h b/arch/arch-arm.h
|
||||
index fc1c4844..78cb2ebe 100644
|
||||
--- a/arch/arch-arm.h
|
||||
+++ b/arch/arch-arm.h
|
||||
@@ -7,7 +7,7 @@
|
||||
|| defined (__ARM_ARCH_5__) || defined (__ARM_ARCH_5T__) || defined (__ARM_ARCH_5E__)\
|
||||
|| defined (__ARM_ARCH_5TE__) || defined (__ARM_ARCH_5TEJ__) \
|
||||
|| defined(__ARM_ARCH_6__) || defined(__ARM_ARCH_6J__) || defined(__ARM_ARCH_6Z__) || defined(__ARM_ARCH_6ZK__) \
|
||||
- || defined(__ARM_ARCH_6KZ__)
|
||||
+ || defined(__ARM_ARCH_6KZ__) || defined(__ARM_ARCH_6K__)
|
||||
#define nop __asm__ __volatile__("mov\tr0,r0\t@ nop\n\t")
|
||||
#define read_barrier() __asm__ __volatile__ ("" : : : "memory")
|
||||
#define write_barrier() __asm__ __volatile__ ("" : : : "memory")
|
||||
--
|
||||
2.17.1
|
||||
|
Loading…
Reference in a new issue