mpd: Update to 0.23.13
ver 0.23.13 (2023/05/22) * input - curl: fix busy loop after connection failed - curl: hide "404" log messages for non-existent ".mpdignore" files * archive - zzip: fix crash bug * database - simple: reveal hidden songs after deleting containing CUE * decoder - ffmpeg: reorder to a lower priority than "gme" - gme: require GME 0.6 or later * output - pipewire: fix corruption bug due to missing lock * Linux - shut down if parent process dies in --no-daemon mode - determine systemd unit directories via pkg-config * support libfmt 10 ver 0.23.12 (2023/01/17) * input - curl: require CURL 7.55.0 or later * decoder - mad: fix integer underflow with very small files * tags - fix crash bug due to race condition * output - pipewire: adjust to PipeWire 0.3.64 API change * fix build failures with GCC 13 Removed upstreamed patch. Signed-off-by: Tianling Shen <cnsztl@immortalwrt.org>
This commit is contained in:
parent
0b99bec49b
commit
f43e7a5067
3 changed files with 3 additions and 33 deletions
|
@ -6,12 +6,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=mpd
|
||||
PKG_VERSION:=0.23.11
|
||||
PKG_VERSION:=0.23.13
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=https://www.musicpd.org/download/mpd/0.23
|
||||
PKG_HASH:=edb4e7a8f9dff238b5610f9e2461940ea98c727a5462fafb1cdf836304dfdca9
|
||||
PKG_HASH:=a96b01e6fbbb7e8ab25eb7c15d5c811c62eb19b76d143a802f51674791f1d519
|
||||
|
||||
PKG_MAINTAINER:=
|
||||
PKG_LICENSE:=GPL-2.0-or-later
|
||||
|
|
|
@ -1,30 +0,0 @@
|
|||
From e4b055eb6d08c5c8f8d85828ce4005d410e462cb Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
|
||||
<congdanhqx@gmail.com>
|
||||
Date: Thu, 1 Dec 2022 08:29:23 +0700
|
||||
Subject: [PATCH] v0.23.x: RemoteTagCache: add missing include
|
||||
|
||||
Fix build with Boost 1.81.0. `<array>` was included by one of those boost headers,
|
||||
however, it's no longer included as of Boost 1.81.0.
|
||||
|
||||
`master` doesn't use `std::array` in this file.
|
||||
|
||||
While we're at it, add all necessary inclusion files.
|
||||
---
|
||||
src/RemoteTagCache.hxx | 4 ++++
|
||||
1 file changed, 4 insertions(+)
|
||||
|
||||
--- a/src/RemoteTagCache.hxx
|
||||
+++ b/src/RemoteTagCache.hxx
|
||||
@@ -28,7 +28,11 @@
|
||||
#include <boost/intrusive/list.hpp>
|
||||
#include <boost/intrusive/unordered_set.hpp>
|
||||
|
||||
+#include <array>
|
||||
+#include <functional>
|
||||
+#include <memory>
|
||||
#include <string>
|
||||
+#include <utility>
|
||||
|
||||
class RemoteTagCacheHandler;
|
||||
|
|
@ -11,4 +11,4 @@
|
|||
-endif
|
||||
conf.set('HAVE_LIBAVFILTER', libavfilter_dep.found())
|
||||
|
||||
if not enable_ffmpeg
|
||||
if not libavutil_dep.found()
|
||||
|
|
Loading…
Reference in a new issue