Merge pull request #5102 from wigyori/for-15.05-xupnpd
CC: multimedia/xupnpd: move download source and upgrade to 2016-07-06
This commit is contained in:
commit
f3e4493e0b
3 changed files with 20 additions and 16 deletions
|
@ -1,5 +1,5 @@
|
|||
#
|
||||
# Copyright (C) 2013-2015 OpenWrt.org
|
||||
# Copyright (C) 2013-2016 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
|
@ -8,15 +8,19 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=xupnpd
|
||||
PKG_REV:=404
|
||||
PKG_VERSION:=$(PKG_REV)
|
||||
PKG_REV:=5c08c051caa0062cc1c401b2d26d1f36dffe9c55
|
||||
PKG_VERSION:=2016-07-06
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE_PROTO:=svn
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_VERSION:=$(PKG_REV)
|
||||
PKG_SOURCE_SUBDIR:=xupnpd-$(PKG_VERSION)
|
||||
PKG_SOURCE_URL:=http://tsdemuxer.googlecode.com/svn/trunk/xupnpd/src/
|
||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_SOURCE_URL:=https://github.com/clark15b/xupnpd.git
|
||||
PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.gz
|
||||
|
||||
PKG_LICENSE:=GPLv2
|
||||
PKG_LICENSE_FILES:=LICENSE
|
||||
|
||||
PKG_MAINTAINER:=Álvaro Fernández Rojas <noltari@gmail.com>
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
@ -24,7 +28,7 @@ include $(INCLUDE_DIR)/package.mk
|
|||
LUA_FLAGS:=-llua
|
||||
|
||||
define Build/Compile
|
||||
(cd $(PKG_BUILD_DIR); $(TARGET_CC) -v $(LUA_FLAGS) $(TARGET_CFLAGS) -fno-exceptions -fno-rtti -DWITH_URANDOM $(TARGET_CPPFLAGS) $(TARGET_LDFLAGS) -lm -ldl -lcrypt -o xupnpd *.c *.cpp)
|
||||
(cd $(PKG_BUILD_DIR)/src; $(TARGET_CC) -v $(LUA_FLAGS) $(TARGET_CFLAGS) -fno-exceptions -fno-rtti -DWITH_URANDOM $(TARGET_CPPFLAGS) $(TARGET_LDFLAGS) -lm -ldl -lcrypt -o xupnpd *.c *.cpp)
|
||||
endef
|
||||
|
||||
define Package/xupnpd
|
||||
|
@ -50,18 +54,18 @@ endef
|
|||
|
||||
define Package/xupnpd/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/xupnpd $(1)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/xupnpd $(1)/usr/bin
|
||||
$(INSTALL_DIR) $(1)/etc/init.d
|
||||
$(INSTALL_BIN) ./files/xupnpd.init $(1)/etc/init.d/xupnpd
|
||||
$(INSTALL_DIR) $(1)/usr/share/xupnpd
|
||||
$(CP) $(PKG_BUILD_DIR)/*.lua $(1)/usr/share/xupnpd
|
||||
$(CP) $(PKG_BUILD_DIR)/src/*.lua $(1)/usr/share/xupnpd
|
||||
$(INSTALL_DIR) $(1)/usr/share/xupnpd/ui
|
||||
$(CP) $(PKG_BUILD_DIR)/ui/* $(1)/usr/share/xupnpd/ui
|
||||
$(CP) $(PKG_BUILD_DIR)/src/ui/* $(1)/usr/share/xupnpd/ui
|
||||
$(INSTALL_DIR) $(1)/usr/share/xupnpd/www
|
||||
$(CP) $(PKG_BUILD_DIR)/www/* $(1)/usr/share/xupnpd/www
|
||||
$(CP) $(PKG_BUILD_DIR)/src/www/* $(1)/usr/share/xupnpd/www
|
||||
$(INSTALL_DIR) $(1)/usr/share/xupnpd/playlists
|
||||
$(INSTALL_DIR) $(1)/usr/share/xupnpd/plugins
|
||||
$(CP) $(PKG_BUILD_DIR)/plugins/* $(1)/usr/share/xupnpd/plugins
|
||||
$(CP) $(PKG_BUILD_DIR)/src/plugins/* $(1)/usr/share/xupnpd/plugins
|
||||
$(INSTALL_DIR) $(1)/usr/share/xupnpd/config
|
||||
$(INSTALL_DIR) $(1)/etc/xupnpd
|
||||
(cd $(1)/etc/xupnpd; ln -s ../../usr/share/xupnpd/config ./; ln -s ../../usr/share/xupnpd/xupnpd.lua ./)
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- a/xupnpd.lua
|
||||
+++ b/xupnpd.lua
|
||||
--- a/src/xupnpd.lua
|
||||
+++ b/src/xupnpd.lua
|
||||
@@ -1,10 +1,10 @@
|
||||
cfg={}
|
||||
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- a/main.cpp
|
||||
+++ b/main.cpp
|
||||
--- a/src/main.cpp
|
||||
+++ b/src/main.cpp
|
||||
@@ -4,11 +4,14 @@
|
||||
* https://tsdemuxer.googlecode.com/svn/trunk/xupnpd
|
||||
*/
|
||||
|
|
Loading…
Reference in a new issue