Merge pull request #10511 from SibrenVasse/openssh8.1

openssh: update to 8.1p1
This commit is contained in:
Josef Schlehofer 2019-11-28 09:27:58 +01:00 committed by GitHub
commit f39cdba7c0
No known key found for this signature in database
GPG key ID: 4AEE18F83AFDEB23
2 changed files with 3 additions and 25 deletions

View file

@ -8,14 +8,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=openssh
PKG_VERSION:=8.0p1
PKG_RELEASE:=2
PKG_VERSION:=8.1p1
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/ \
https://ftp.spline.de/pub/OpenBSD/OpenSSH/portable/ \
https://anorien.csc.warwick.ac.uk/pub/OpenBSD/OpenSSH/portable/
PKG_HASH:=bd943879e69498e8031eb6b7f44d08cdc37d59a7ab689aa0b437320c3481fd68
PKG_HASH:=02f5dbef3835d0753556f973cd57b4c19b6b1f6cd24c03445e23ac77ca1b93ff
PKG_LICENSE:=BSD ISC
PKG_LICENSE_FILES:=LICENCE

View file

@ -1,22 +0,0 @@
From 73eb6cef41daba0359c1888e4756108d41b4e819 Mon Sep 17 00:00:00 2001
From: Darren Tucker <dtucker@dtucker.net>
Date: Sun, 16 Jun 2019 12:55:27 +1000
Subject: [PATCH] Include stdio.h for vsnprintf.
Patch from mforney at mforney.org.
---
openbsd-compat/setproctitle.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/openbsd-compat/setproctitle.c b/openbsd-compat/setproctitle.c
index dbd1a95a0..e4064323a 100644
--- a/openbsd-compat/setproctitle.c
+++ b/openbsd-compat/setproctitle.c
@@ -36,6 +36,7 @@
#ifndef HAVE_SETPROCTITLE
#include <stdarg.h>
+#include <stdio.h>
#include <stdlib.h>
#include <unistd.h>
#ifdef HAVE_SYS_PSTAT_H