gkermit: Fix compilation with -Wimplicit-function-declaration
Cleaned up Makefile for consistency between packages. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
48ada8aaf3
commit
f33345f2f2
2 changed files with 33 additions and 3 deletions
|
@ -8,15 +8,15 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=gkermit
|
||||
PKG_VERSION:=1.00
|
||||
PKG_RELEASE:=1
|
||||
PKG_LICENSE:=GPL-2.0
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=gku100.tar.gz
|
||||
PKG_SOURCE_URL:=ftp://kermit.columbia.edu/kermit/archives
|
||||
PKG_HASH:=3dbe63291277c4795255343b48b860777fb0a160163d7e1d30b1ee68585593eb
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
|
||||
PKG_MAINTAINER:=Nathaniel Wesley Filardo <nwfilardo@gmail.com>
|
||||
PKG_LICENSE:=GPL-2.0-or-later
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
|
@ -34,6 +34,7 @@ endef
|
|||
define Build/Prepare
|
||||
mkdir -p $(PKG_BUILD_DIR)
|
||||
tar -C $(PKG_BUILD_DIR) -xzvf "$(DL_DIR)/$(PKG_SOURCE)"
|
||||
$(Build/Patch)
|
||||
endef
|
||||
|
||||
# nothing to do
|
||||
|
|
29
utils/gkermit/patches/010-musl.patch
Normal file
29
utils/gkermit/patches/010-musl.patch
Normal file
|
@ -0,0 +1,29 @@
|
|||
--- a/gcmdline.c
|
||||
+++ b/gcmdline.c
|
||||
@@ -29,6 +29,7 @@
|
||||
*/
|
||||
|
||||
#include <stdio.h>
|
||||
+#include <stdlib.h>
|
||||
#include "gkermit.h"
|
||||
|
||||
/* Externals */
|
||||
@@ -53,7 +54,7 @@ _MYPROTOTYPE( VOID fatal, (char *) );
|
||||
_MYPROTOTYPE( VOID usage, (void) );
|
||||
|
||||
#ifndef NOGETENV
|
||||
-_MYPROTOTYPE( char * getenv, (char *) );
|
||||
+_MYPROTOTYPE( char * getenv, (const char *) );
|
||||
#define GARGC 32
|
||||
#define GBUFSIZ 256
|
||||
static char gbuf[GBUFSIZ], *gargs[GARGC], *gptr = NULL;
|
||||
--- a/gunixio.c
|
||||
+++ b/gunixio.c
|
||||
@@ -58,6 +58,7 @@
|
||||
*/
|
||||
|
||||
#include <stdio.h> /* Standard input/output */
|
||||
+#include <stdlib.h>
|
||||
|
||||
#ifdef POSIX
|
||||
#include <termios.h> /* Terminal modes */
|
Loading…
Reference in a new issue