minicom: fix iconv dependencies, music includes and musl compatibility
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
This commit is contained in:
parent
2865b5aa09
commit
f2cc485dfe
3 changed files with 31 additions and 3 deletions
|
@ -1,5 +1,5 @@
|
|||
#
|
||||
# Copyright (C) 2006-2014 OpenWrt.org
|
||||
# Copyright (C) 2006-2015 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=minicom
|
||||
PKG_VERSION:=2.7
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://alioth.debian.org/frs/download.php/file/3977/
|
||||
|
@ -21,12 +21,13 @@ PKG_LICENSE_FILES:=COPYING
|
|||
|
||||
PKG_FIXUP:=autoreconf
|
||||
|
||||
include $(INCLUDE_DIR)/nls.mk
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/minicom
|
||||
SECTION:=utils
|
||||
CATEGORY:=Utilities
|
||||
DEPENDS:=+libncurses
|
||||
DEPENDS:=$(ICONV_DEPENDS) +libncurses
|
||||
TITLE:=Terminal emulation program
|
||||
URL:=http://alioth.debian.org/projects/minicom/
|
||||
SUBMENU:=Terminal
|
||||
|
|
14
utils/minicom/patches/101-fix_music_includes.patch
Normal file
14
utils/minicom/patches/101-fix_music_includes.patch
Normal file
|
@ -0,0 +1,14 @@
|
|||
--- a/src/dial.c
|
||||
+++ b/src/dial.c
|
||||
@@ -39,11 +39,9 @@
|
||||
#include "intl.h"
|
||||
|
||||
#ifdef VC_MUSIC
|
||||
-# if defined(__GLIBC__)
|
||||
# include <sys/ioctl.h>
|
||||
# include <sys/kd.h>
|
||||
# include <sys/time.h>
|
||||
-# endif
|
||||
#endif
|
||||
|
||||
enum { CURRENT_VERSION = 6 };
|
13
utils/minicom/patches/102-fix_musl_compatibility.patch
Normal file
13
utils/minicom/patches/102-fix_musl_compatibility.patch
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- a/src/getsdir.h
|
||||
+++ b/src/getsdir.h
|
||||
@@ -24,6 +24,10 @@
|
||||
|
||||
#include <dirent.h>
|
||||
|
||||
+#ifndef MAXNAMLEN
|
||||
+#define MAXNAMLEN 255
|
||||
+#endif
|
||||
+
|
||||
typedef struct dirEntry { /* structure of data item */
|
||||
char fname[MAXNAMLEN + 1]; /* filename + terminating null */
|
||||
time_t time; /* last modification date */
|
Loading…
Reference in a new issue