utils/pcsc-tools: Add to repo
Add pcsc-tools to repo Signed-off-by: Daniel Engberg <daniel.engberg.lists@pyret.net>
This commit is contained in:
parent
31db48a506
commit
f2c5ffed1e
2 changed files with 60 additions and 0 deletions
43
utils/pcsc-tools/Makefile
Normal file
43
utils/pcsc-tools/Makefile
Normal file
|
@ -0,0 +1,43 @@
|
|||
#
|
||||
# Copyright (C) 2017 Daniel Engberg <daniel.engberg.lists@pyret.net>
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=pcsc-tools
|
||||
PKG_VERSION=1.5.2
|
||||
PKG_RELEASE:=1
|
||||
PKG_MAINTAINER:=Daniel Engberg <daniel.engberg.lists@pyret.net>
|
||||
PKG_LICENSE:=GPL-2.0
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=http://ludovic.rousseau.free.fr/softwares/pcsc-tools/
|
||||
PKG_HASH:=ff4e087c76700aa5a25dd7d0bc4f55bb4a5e71cd4f0d6b5301babe0b434f86fc
|
||||
|
||||
PKG_FIXUP:=autoreconf
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/pcsc-tools
|
||||
SECTION:=utils
|
||||
CATEGORY:=Utilities
|
||||
DEPENDS:=+libpcsclite
|
||||
TITLE:=pcsc-tools
|
||||
URL:=http://ludovic.rousseau.free.fr/softwares/pcsc-tools/
|
||||
endef
|
||||
|
||||
define Package/pcsc-tools/description
|
||||
Tools that are used to test a PC/SC driver, card or reader.
|
||||
Only includes pcsc_scan without ATR analysis for now.
|
||||
endef
|
||||
|
||||
define Package/pcsc-tools/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/pcsc_scan $(1)/usr/bin
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,pcsc-tools))
|
17
utils/pcsc-tools/patches/001-disable-atr.patch
Normal file
17
utils/pcsc-tools/patches/001-disable-atr.patch
Normal file
|
@ -0,0 +1,17 @@
|
|||
Windows (Win32) doesn't support the analyze ATR perl-script and since we
|
||||
don't want to pull in perl as a dependency add the same workaround here.
|
||||
|
||||
diff --git a/pcsc_scan.c b/pcsc_scan.c
|
||||
index e1d8942..81344e1 100644
|
||||
--- a/pcsc_scan.c
|
||||
+++ b/pcsc_scan.c
|
||||
@@ -224,9 +224,7 @@ int main(int argc, char *argv[])
|
||||
printf("PC/SC device scanner\n");
|
||||
printf("V " PACKAGE_VERSION " (c) 2001-2017, Ludovic Rousseau <ludovic.rousseau@free.fr>\n");
|
||||
|
||||
-#ifdef WIN32
|
||||
analyse_atr = FALSE;
|
||||
-#endif
|
||||
|
||||
while ((opt = getopt(argc, argv, "Vhns")) != EOF)
|
||||
{
|
Loading…
Reference in a new issue