vips: update to 8.10.15
Refresh patches. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
55593507ab
commit
f28ff82483
3 changed files with 12 additions and 15 deletions
libs/vips
|
@ -6,12 +6,12 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=vips
|
PKG_NAME:=vips
|
||||||
PKG_VERSION:=8.10.2
|
PKG_VERSION:=8.10.5
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=https://github.com/libvips/libvips/releases/download/v$(PKG_VERSION)
|
PKG_SOURCE_URL:=https://github.com/libvips/libvips/releases/download/v$(PKG_VERSION)
|
||||||
PKG_HASH:=c1d0d9cb54d75cd4f66dce787fbcac99f834f6621fbf47bce9e02ef65b4ab02a
|
PKG_HASH:=a4eef2f5334ab6dbf133cd3c6d6394d5bdb3e76d5ea4d578b02e1bc3d9e1cfd8
|
||||||
|
|
||||||
PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
|
PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
|
||||||
PKG_LICENSE:=LGPL-2.1-or-later
|
PKG_LICENSE:=LGPL-2.1-or-later
|
||||||
|
|
|
@ -1,7 +1,6 @@
|
||||||
diff -u --recursive vips-8.10.2-vanilla/configure.ac vips-8.10.2/configure.ac
|
--- a/configure.ac
|
||||||
--- vips-8.10.2-vanilla/configure.ac 2020-10-12 11:43:59.000000000 -0500
|
+++ b/configure.ac
|
||||||
+++ vips-8.10.2/configure.ac 2020-11-19 12:17:39.393295442 -0600
|
@@ -53,9 +53,6 @@ AC_SUBST(LIBRARY_CURRENT)
|
||||||
@@ -53,9 +53,6 @@
|
|
||||||
AC_SUBST(LIBRARY_REVISION)
|
AC_SUBST(LIBRARY_REVISION)
|
||||||
AC_SUBST(LIBRARY_AGE)
|
AC_SUBST(LIBRARY_AGE)
|
||||||
|
|
||||||
|
@ -11,10 +10,9 @@ diff -u --recursive vips-8.10.2-vanilla/configure.ac vips-8.10.2/configure.ac
|
||||||
# remove the '(disabled, use --enable-introspection to enable)'
|
# remove the '(disabled, use --enable-introspection to enable)'
|
||||||
# suffix from the found_introspection variable
|
# suffix from the found_introspection variable
|
||||||
if test "x$found_introspection" != x"yes"; then
|
if test "x$found_introspection" != x"yes"; then
|
||||||
diff -u --recursive vips-8.10.2-vanilla/libvips/Makefile.am vips-8.10.2/libvips/Makefile.am
|
--- a/libvips/Makefile.am
|
||||||
--- vips-8.10.2-vanilla/libvips/Makefile.am 2020-09-14 10:38:03.000000000 -0500
|
+++ b/libvips/Makefile.am
|
||||||
+++ vips-8.10.2/libvips/Makefile.am 2020-11-19 12:18:08.473384766 -0600
|
@@ -67,56 +67,3 @@ install-exec-hook:
|
||||||
@@ -67,56 +67,3 @@
|
|
||||||
echo "#define VIPS_SONAME \"$$dlname\"" >> soname.h && \
|
echo "#define VIPS_SONAME \"$$dlname\"" >> soname.h && \
|
||||||
cp soname.h $(DESTDIR)$(pkgincludedir) && \
|
cp soname.h $(DESTDIR)$(pkgincludedir) && \
|
||||||
rm soname.h
|
rm soname.h
|
||||||
|
|
|
@ -1,7 +1,6 @@
|
||||||
diff -u --recursive vips-8.10.2-vanilla/configure.ac vips-8.10.2/configure.ac
|
--- a/configure.ac
|
||||||
--- vips-8.10.2-vanilla/configure.ac 2020-10-12 11:43:59.000000000 -0500
|
+++ b/configure.ac
|
||||||
+++ vips-8.10.2/configure.ac 2020-11-19 12:16:45.187129100 -0600
|
@@ -26,7 +26,11 @@ VIPS_MAJOR_VERSION=vips_major_version()
|
||||||
@@ -26,7 +26,11 @@
|
|
||||||
VIPS_MINOR_VERSION=vips_minor_version()
|
VIPS_MINOR_VERSION=vips_minor_version()
|
||||||
VIPS_MICRO_VERSION=vips_micro_version()
|
VIPS_MICRO_VERSION=vips_micro_version()
|
||||||
VIPS_VERSION=vips_version()
|
VIPS_VERSION=vips_version()
|
||||||
|
|
Loading…
Reference in a new issue