hcxtools: update to 6.1.6
Add patch fixing compilation without deprecated OpenSSL APIs. Fix installation. This never worked as the section was misnamed. Updated tool names. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
e1d8f4fc96
commit
f25755b0f9
2 changed files with 100 additions and 23 deletions
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=hcxtools
|
||||
PKG_VERSION:=5.3.0
|
||||
PKG_RELEASE:=1
|
||||
PKG_VERSION:=6.1.6
|
||||
PKG_RELEASE:=$(AUTORELEASE)
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/zerbea/hcxtools/tar.gz/$(PKG_VERSION)?
|
||||
PKG_HASH:=bc3465eb3b97c4db849af41ae3fa7c812d4683eb9e493f090ac82e922ba8a36d
|
||||
PKG_HASH:=27b1b1ad722b9d82f8e92c6bec92d081159e5b8225bd2a477bf8d304ff4aeb03
|
||||
|
||||
PKG_MAINTAINER:=Andreas Nilsen <adde88@gmail.com>
|
||||
PKG_LICENSE:=MIT
|
||||
|
@ -41,29 +41,21 @@ define Build/Compile
|
|||
CFLAGS="$(TARGET_CFLAGS)"
|
||||
endef
|
||||
|
||||
define Package/hcxtools-custom/install
|
||||
define Package/hcxtools/install
|
||||
$(INSTALL_DIR) $(1)/sbin
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxpcapngtool $(1)/sbin/
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxhashtool $(1)/sbin/
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxpsktool $(1)/sbin/
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxwltool $(1)/sbin/
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/wlancap2wpasec $(1)/sbin/
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/whoismac $(1)/sbin/
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxpmkidtool $(1)/sbin/
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/wlanhcx2john $(1)/sbin/
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxpcaptool $(1)/sbin/
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxhashcattool $(1)/sbin/
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxmactool $(1)/sbin/
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxeiutool $(1)/sbin/
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxessidtool $(1)/sbin/
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxhash2cap $(1)/sbin/
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/wlanhc2hcx $(1)/sbin/
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/wlanwkp2hcx $(1)/sbin/
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/wlanhcxinfo $(1)/sbin/
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/wlanhcx2ssid $(1)/sbin/
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/wlanhcxcat $(1)/sbin/
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/wlanpmk2hcx $(1)/sbin/
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/wlanjohn2hcx $(1)/sbin/
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/wlancow2hcxpmk $(1)/sbin/
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxhashcattool $(1)/sbin/
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxhashtool $(1)/sbin/
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxmactool $(1)/sbin/
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxpcapngtool $(1)/sbin/
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxpmkidtool $(1)/sbin/
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxpmktool $(1)/sbin/
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxpsktool $(1)/sbin/
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxwltool $(1)/sbin/
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/whoismac $(1)/sbin/
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/wlancap2wpasec $(1)/sbin/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,hcxtools))
|
||||
|
|
85
net/hcxtools/patches/010-openssl.patch
Normal file
85
net/hcxtools/patches/010-openssl.patch
Normal file
|
@ -0,0 +1,85 @@
|
|||
--- a/hcxhashtool.c
|
||||
+++ b/hcxhashtool.c
|
||||
@@ -104,9 +104,6 @@ static void closelists()
|
||||
{
|
||||
if(hashlist != NULL) free(hashlist);
|
||||
if(ouilist != NULL) free(ouilist);
|
||||
-EVP_cleanup();
|
||||
-CRYPTO_cleanup_all_ex_data();
|
||||
-ERR_free_strings();
|
||||
return;
|
||||
}
|
||||
/*===========================================================================*/
|
||||
@@ -125,8 +122,6 @@ eapolwrittencount = 0;
|
||||
essidwrittencount = 0;
|
||||
hccapxwrittencount = 0;
|
||||
hccapwrittencount = 0;
|
||||
-ERR_load_crypto_strings();
|
||||
-OpenSSL_add_all_algorithms();
|
||||
if((hashlist = (hashlist_t*)calloc(hashlistcount, HASHLIST_SIZE)) == NULL) return false;
|
||||
if((ouilist = (ouilist_t*)calloc(ouilistcount, OUILIST_SIZE)) == NULL) return false;
|
||||
return true;
|
||||
--- a/hcxpcapngtool.c
|
||||
+++ b/hcxpcapngtool.c
|
||||
@@ -358,9 +358,6 @@ if(eapmschapv2msglist != NULL) free(eapm
|
||||
if(eapmschapv2hashlist != NULL) free(eapmschapv2hashlist);
|
||||
if(tacacsplist != NULL) free(tacacsplist);
|
||||
|
||||
-EVP_cleanup();
|
||||
-CRYPTO_cleanup_all_ex_data();
|
||||
-ERR_free_strings();
|
||||
return;
|
||||
}
|
||||
/*===========================================================================*/
|
||||
@@ -369,8 +366,6 @@ static bool initlists()
|
||||
static unsigned long opensslversion;
|
||||
static const char nastring[] = { "N/A" };
|
||||
|
||||
-ERR_load_crypto_strings();
|
||||
-OpenSSL_add_all_algorithms();
|
||||
opensslversion = OpenSSL_version_num();
|
||||
opensslversionmajor = (opensslversion & 0x10000000L) >> 28;
|
||||
opensslversionminor = (opensslversion & 0x01100000L) >> 20;
|
||||
--- a/hcxpmktool.c
|
||||
+++ b/hcxpmktool.c
|
||||
@@ -920,8 +920,6 @@ while((auswahl = getopt_long(argc, argv,
|
||||
}
|
||||
}
|
||||
|
||||
-ERR_load_crypto_strings();
|
||||
-OpenSSL_add_all_algorithms();
|
||||
printf("\n");
|
||||
if((essidstring != NULL) && (pskstring != NULL) && (pmkstring == NULL) && (hashlinestring == NULL))
|
||||
{
|
||||
@@ -953,9 +951,6 @@ else if((essidstring != NULL) && (pskstr
|
||||
}
|
||||
|
||||
printf("\n");
|
||||
-EVP_cleanup();
|
||||
-CRYPTO_cleanup_all_ex_data();
|
||||
-ERR_free_strings();
|
||||
return EXIT_SUCCESS;
|
||||
}
|
||||
/*===========================================================================*/
|
||||
--- a/hcxpsktool.c
|
||||
+++ b/hcxpsktool.c
|
||||
@@ -61,8 +61,6 @@ essidglen = 32;
|
||||
t = time(NULL);
|
||||
tm = localtime(&t);
|
||||
thisyear = tm->tm_year +1900;
|
||||
-ERR_load_crypto_strings();
|
||||
-OpenSSL_add_all_algorithms();
|
||||
return;
|
||||
}
|
||||
/*===========================================================================*/
|
||||
@@ -2770,10 +2768,6 @@ if(pskname != NULL)
|
||||
fclose(fhpsk);
|
||||
}
|
||||
|
||||
-EVP_cleanup();
|
||||
-CRYPTO_cleanup_all_ex_data();
|
||||
-ERR_free_strings();
|
||||
-
|
||||
return EXIT_SUCCESS;
|
||||
}
|
||||
/*===========================================================================*/
|
Loading…
Reference in a new issue