kea: update package to 1.6.0
Update kea to the latest stable verion (1.6.0).
Signed-off-by: Tiago Gaspar <tiagogaspar8@gmail.com>
(cherry picked from commit 03cf093332
)
This commit is contained in:
parent
6f19b894d6
commit
f22e122e64
3 changed files with 54 additions and 58 deletions
|
@ -9,12 +9,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=kea
|
||||
PKG_VERSION:=1.5.0
|
||||
PKG_RELEASE:=5
|
||||
PKG_VERSION:=1.6.0
|
||||
PKG_RELEASE:=6
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://ftp.isc.org/isc/kea/$(PKG_VERSION)
|
||||
PKG_HASH:=edce4fab68ca7af607cf7f5bc86596e04fe0ef4b8e88906e339cdefcf21daaec
|
||||
PKG_HASH:=44ed48c729e4618fffcf0086529b469f7232990983187b2f71fce89f1ac6e270
|
||||
|
||||
PKG_MAINTAINER:=BangLang Huang<banglang.huang@foxmail.com>, Rosy Song<rosysong@rosinson.com>
|
||||
PKG_LICENSE:=MPL-2.0
|
||||
|
@ -149,7 +149,8 @@ HOST_CONFIGURE_ARGS += \
|
|||
--with-log4cplus="$(STAGING_DIR_HOSTPKG)" \
|
||||
--with-openssl="$(STAGING_DIR)/usr" \
|
||||
--enable-boost-headers-only \
|
||||
--enable-static-link
|
||||
--enable-static-link \
|
||||
--enable-generate-messages
|
||||
|
||||
HOST_LDFLAGS += \
|
||||
-Wl,--gc-sections,--as-needed
|
||||
|
@ -229,7 +230,6 @@ define Package/kea-ctrl/install
|
|||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/kea-ctrl-agent $(1)/usr/sbin/kea-ctrl-agent
|
||||
$(CP) $(PKG_INSTALL_DIR)/etc/kea/keactrl.conf $(1)/etc/kea/
|
||||
$(CP) $(PKG_INSTALL_DIR)/etc/kea/kea-ctrl-agent.conf $(1)/etc/kea/
|
||||
$(CP) $(PKG_INSTALL_DIR)/etc/kea/kea-netconf.conf $(1)/etc/kea/
|
||||
endef
|
||||
|
||||
define Package/kea-lfc/install
|
||||
|
|
|
@ -1,8 +1,6 @@
|
|||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -580,10 +580,10 @@ AC_TRY_COMPILE([
|
||||
AC_MSG_RESULT(no))
|
||||
|
||||
@@ -542,8 +542,8 @@ AC_TRY_COMPILE([
|
||||
AC_MSG_CHECKING(for usuable C++11 regex)
|
||||
-AC_TRY_RUN([
|
||||
+AC_TRY_COMPILE([
|
||||
|
|
|
@ -252,11 +252,9 @@
|
|||
AM_CPPFLAGS += $(BOOST_INCLUDES)
|
||||
--- a/src/lib/log/Makefile.am
|
||||
+++ b/src/lib/log/Makefile.am
|
||||
@@ -2,7 +2,6 @@ SUBDIRS = interprocess .
|
||||
if !CROSS_COMPILING
|
||||
SUBDIRS += compiler
|
||||
endif
|
||||
-SUBDIRS += tests
|
||||
@@ -1,4 +1,4 @@
|
||||
-SUBDIRS = interprocess . compiler tests
|
||||
+SUBDIRS = interprocess . compiler
|
||||
|
||||
AM_CPPFLAGS = -I$(top_builddir)/src/lib -I$(top_srcdir)/src/lib
|
||||
AM_CPPFLAGS += $(BOOST_INCLUDES)
|
||||
|
@ -289,9 +287,9 @@
|
|||
@@ -1,4 +1,4 @@
|
||||
-SUBDIRS = . testutils tests
|
||||
+SUBDIRS = .
|
||||
dhcp_data_dir = @localstatedir@/@PACKAGE@
|
||||
# DATA_DIR is the directory where to put PID files.
|
||||
dhcp_data_dir = @runstatedir@/@PACKAGE@
|
||||
AM_CPPFLAGS = -I$(top_builddir)/src/lib -I$(top_srcdir)/src/lib
|
||||
AM_CPPFLAGS += -DDATA_DIR="\"$(dhcp_data_dir)\""
|
||||
--- a/src/lib/stats/Makefile.am
|
||||
+++ b/src/lib/stats/Makefile.am
|
||||
@@ -1,4 +1,4 @@
|
||||
|
|
Loading…
Reference in a new issue