lvm2: update to version 2.03.13
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
This commit is contained in:
parent
ab5050ed65
commit
f20f69e63b
3 changed files with 8 additions and 8 deletions
|
@ -9,12 +9,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=LVM2
|
||||
PKG_VERSION:=2.03.12
|
||||
PKG_VERSION:=2.03.13
|
||||
PKG_RELEASE:=$(AUTORELEASE)
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME).$(PKG_VERSION).tgz
|
||||
PKG_SOURCE_URL:=https://sourceware.org/pub/lvm2
|
||||
PKG_HASH:=76075cf2a2dd12ef526a583f0b3c72a6deaa10691fab28216b0821d01cff0cea
|
||||
PKG_HASH:=296b9c8769e6b5b8e81128a1c0aeb58e6da1f0fcf97dba90ad3f005ece53a568
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/lvm2-$(BUILD_VARIANT)/$(PKG_NAME).$(PKG_VERSION)
|
||||
|
||||
PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/lib/commands/toolcontext.c
|
||||
+++ b/lib/commands/toolcontext.c
|
||||
@@ -1619,7 +1619,7 @@ struct cmd_context *create_toolcontext(u
|
||||
@@ -1627,7 +1627,7 @@ struct cmd_context *create_toolcontext(u
|
||||
/* FIXME Make this configurable? */
|
||||
reset_lvm_errno(1);
|
||||
|
||||
|
@ -9,7 +9,7 @@
|
|||
/* Set in/out stream buffering before glibc */
|
||||
if (set_buffering
|
||||
#ifdef SYS_gettid
|
||||
@@ -2006,7 +2006,7 @@ void destroy_toolcontext(struct cmd_cont
|
||||
@@ -2014,7 +2014,7 @@ void destroy_toolcontext(struct cmd_cont
|
||||
|
||||
if (cmd->pending_delete_mem)
|
||||
dm_pool_destroy(cmd->pending_delete_mem);
|
||||
|
@ -20,7 +20,7 @@
|
|||
if (is_valid_fd(STDIN_FILENO) &&
|
||||
--- a/tools/lvmcmdline.c
|
||||
+++ b/tools/lvmcmdline.c
|
||||
@@ -3339,6 +3339,7 @@ int lvm_split(char *str, int *argc, char
|
||||
@@ -3349,6 +3349,7 @@ int lvm_split(char *str, int *argc, char
|
||||
/* Make sure we have always valid filedescriptors 0,1,2 */
|
||||
static int _check_standard_fds(void)
|
||||
{
|
||||
|
@ -28,7 +28,7 @@
|
|||
int err = is_valid_fd(STDERR_FILENO);
|
||||
|
||||
if (!is_valid_fd(STDIN_FILENO) &&
|
||||
@@ -3365,6 +3366,12 @@ static int _check_standard_fds(void)
|
||||
@@ -3375,6 +3376,12 @@ static int _check_standard_fds(void)
|
||||
strerror(errno));
|
||||
return 0;
|
||||
}
|
||||
|
|
|
@ -10,10 +10,10 @@
|
|||
struct btree_iter *current;
|
||||
--- a/tools/lvmdevices.c
|
||||
+++ b/tools/lvmdevices.c
|
||||
@@ -15,6 +15,7 @@
|
||||
#include "tools.h"
|
||||
@@ -16,6 +16,7 @@
|
||||
#include "lib/cache/lvmcache.h"
|
||||
#include "lib/device/device_id.h"
|
||||
#include "lib/device/dev-type.h"
|
||||
+#include <sys/file.h>
|
||||
|
||||
static void _search_devs_for_pvids(struct cmd_context *cmd, struct dm_list *search_pvids, struct dm_list *found_devs)
|
||||
|
|
Loading…
Reference in a new issue